WordPress.org

Forums

Contact Form 7
[resolved] "Failed to send your message" in Red (13 posts)

  1. gpateire
    Member
    Posted 3 years ago #

    Hello,

    I am having the common problem that others seem to be having with the message, "Failed to send your message. Please try later or contact the administrator by another method."

    Mine comes in red when I try to submit a test message. I have installed "WP-Mail-SMTP" and sent a test email with WP-Mail-SMTP and received it with no problem.

    My web host is iPage.com. Asked them if they could help. No go. Said the server is off of Linux.

    I have deactivated Akismet to see if that was the culprit, but still nothing.

    Any help is greatly appreciated.

    http://www.backpainrelief.com/backpainrelief.com/contact-us/

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 3 years ago #

    Was it working before?

    What other plugins do you use?

  3. gpateire
    Member
    Posted 3 years ago #

    Was it working before?

    What other plugins do you use?

    Hello,

    It hasn't worked yet since I have put the site together. The other plug ins that I am using on the site are:

    Akismet
    Contact Form 7
    Hello Dolly
    Jetpack by WordPress.com
    Really Simple CAPTCHA
    W3 Total Cache
    Wiziapp
    Wordpress Newsletter subscription Opt-in for SendBlaster
    WP-Mail-SMTP (successfully received test email)
    WP-PageNavi

    In the "edit" section, I have not modified the plug in itself in any way. The "contact-form-7/wp-contact-form-7.php" file is still as they have been when I downloaded the plugin, as are all other files associated with the plugin.

    For the Contact Form 7 "settings," I have the following:
    To: My personal email address
    From: Email address with the domain name (..@backpainrelief.com)
    Subject: "Form Submission: BackPainRelief.com"
    Additional headers: *Blank*
    File attachments: *Blank*
    Use HTML content type: *Unchecked*
    Message body: *Blank*

    I greatly appreciate any feedback you all can provide.

  4. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 3 years ago #

    Message body: *Blank*

    Why? What do you use this form for?

  5. karenbrand
    Member
    Posted 3 years ago #

    I'm having the same exact problem as others. Several clients pointed out that they are getting the red "Failed to send your message. Please try later or contact the administrator by another method" when someone tries to send a message.

    All of my sites having been running just fine with your plugin for about 6 months until now.

    Maybe you made some changes to it???

  6. karenbrand
    Member
    Posted 3 years ago #

    I just installed the WP-Mail-SMTP plugin and it fixed the problem!!

  7. Toshi Yoshida
    Member
    Posted 3 years ago #

    I just updated to the latest version of Contact Form 7 and I get the "Failed to send your message. Please try later or contact the administrator by another method." message.

    For now I've replaced it with another contact plugin that works (as its a live income producting site that's affected) but will retry Contact Form 7 in a week or so to see if its been fixed or if it's just doesn't work for me.

  8. gpateire
    Member
    Posted 3 years ago #

    Message body: *Blank*

    Why? What do you use this form for?

    I am just trying to use it for a "contact us" form. Did I miss something in the directions on anything being a necessity to be placed in the message body for the form to work?

    Thank you for the help, Takayuki Miyoshi.

  9. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 3 years ago #

    The content of the "Message body" field is used for the message body of mail to be sent. That shouldn't be blank.

    To: My personal email address
    From: Email address with the domain name (..@backpainrelief.com)

    You might need to check these fields as well. If these are invalid, sending mail should fail.

  10. soulofmiami
    Member
    Posted 3 years ago #

    This is happening to me, too, intermittently.

    I have determined that it is the second error: "# Sender's message was failed to send" that is happening. Unfortunately, this error does not give me any useful information. It just failed to send for no apparent reason.

    I have the WP-Mail-SMTP installed and it was working fine for a while. I have been using Contact Form 7 for a couple years and, aside from a few problems here and there, it has always worked fine. This is something new.

    I also have Akismet installed, but that does not seem to be the issue.

    Is anyone else experiencing this?

  11. soulofmiami
    Member
    Posted 3 years ago #

    Okay, ignore my previous comment, it is working now. The problem is my webhost, Dreamhost, screwed things up by implementing some ridiculous email protocols. After removing the WP-Mail-SMTP plugin, it now seems to work.

  12. gpateire
    Member
    Posted 3 years ago #

    The content of the "Message body" field is used for the message body of mail to be sent. That shouldn't be blank.

    To: My personal email address
    From: Email address with the domain name (..@backpainrelief.com)

    You might need to check these fields as well. If these are invalid, sending mail should fail.

    I figured it out with your help. Thank you. I was not putting in any of the tags into the message body. Perhaps it is a good idea to read the directions more thoroughly next time.

    YouTube videos did a great job explaining the functionality of this plug-in as well.

  13. threeaz
    Member
    Posted 2 years ago #

    I had the same problem. Deactivated the pluging "WP-Mail-SMTP" and everything works perfectly now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic