WordPress.org

Support

Support » Plugins and Hacks » Contact Form 7 » [Plugin: Contact Form 7] error/success messages dont show.

[Plugin: Contact Form 7] error/success messages dont show.

  • Hey,

    So I just moved hosts today.

    Everything is working fine, except when I hit submit, no error essages show up, it just sits there..

    If I fill out the required fields and hit submit, it send the message, but nothing happens on the page, it just appears to sit there.

    Any ideas?
    I already reinstalled the plugin and repaired the DB.

    http://wordpress.org/extend/plugins/contact-form-7/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Same problem here. Firebug shows the following:

    This AJAX call is sent:
    http://[myurl.com]/contact/#wpcf7-f1-p16-o1

    Which returns the error:
    data is null
    http://[myurl.com]/wp-content/plugins/contact-form-7/scripts.js?ver=2.3
    Line 94

    I’m having the same problem http://sebcastilho.com/contact/
    The arrow just keeps spinning. When I first installed the plugin a few months ago, it worked fine. I haven’t tried using it again till now.

    Looks like this is a bug, but it worked for me my development environment (so that’s the strange part). But you can fix this as follows:

    Open /wp-content/plugins/contact-form-7/scripts.js
    and add -form on lines 3 and 12, so it looks like this:
    jQuery(‘div.wpcf7-form > form’).ajaxForm({

    jQuery(‘div.wpcf7-form > form’).each(function(i, n) {

    That should do the trick. I’ll contact the author, so he can fix it in the next build.

    Grz,
    Jarown

    Thanks! That did the trick for me.

    I created an account just to say thank you Jarown! Your script repair worked perfectly. What a relief. Thank you!

    arelithenoob is right. Jarown’s code fix works. Thanks for taking time to post the solution. I had been troubleshooting the problem for hours.

    Thanks Jarown. It’s worked for me too. But. Whereas CF7 normally gives me the little spinny arrow thing and then a neat pop-up delivers my message, this fix changed things a little.

    Now, after I hit submit it reloads the page and sends me to the top of the page, and appends the URL with “#wpcf7-f3-p3421-o1”.

    Is this normal?

    I appreciate CF7 is free and it’s been developed without pay etc., but it’s so frustrating to see the author just referring people to the same string of FAQs over and over ahain when there is obviously a bigger problem.

    I’m glad for people such as yourself that go the extra mile.

    Plugin Author Takayuki Miyoshi

    @takayukister

    I’m the author of Contact Form 7.

    Just for the record, Jarown’s modification in the upper comment doesn’t fix any problems, unfortunately. It only make Ajax malfunction.

    Because nothing matches this pattern:

    jQuery(‘div.wpcf7-form > form‘).ajaxForm({

    If you just want to disable Ajax feature, add this line into your wp-config.php:

    define ('WPCF7_LOAD_JS', false);

    Then WordPress doesn’t load Contact Form 7’s JavaScript.

    After all, issues mentioned on this topic are typical issues caused by broken theme or conflict with other plugins or theme. Once deactivate all other plugins and switch to the default theme, then you’ll find all problems are cleared.

    Thanks for the response, Takayuki.

    I did deactivate all plugins (other than CF7), and I use the K2 theme which is pretty basic, and nothing fancy (in fact I think it’s pretty similar to the WP default theme itself). I’d prefer not to have to use the WP theme anyway.

    I first disabled the plugins one-by-one, then I disabled them all and the problem stuck.

    I don’t want to disable the Ajax feature, I just want it to work like it used to; I have the common error of the spinning arrow.

    I’ve followed every piece of advice you have kindly given on your FAQs, and yourself and others have given here on the WP forums; and this temporary fix was the only thing that worked for me at this time.

    I’ve reversed it following your post.

    I do appreciate you must get asked a lot of the same questions, and you do it for voluntary donations. This kind of thing isn’t my area of expertise, and I’m open to your thoughts on a possible solution.

    One of a few different CF7 forms on my site can be found here.

    FYI – I was having this same issue and after updating to Contact Form 7, v 7.2.3.1, the AJAX messages and validation began working normally again.

    Thanks for the update Takayuki, works like a charm!

    Thanks for the fix.

    After some thought, I am thinking that it must be a conflict with jquery. Pre-WP3 used older versions of jquery, while WP3 includes a more recent one.

    A post near the end of this thread seems to confirm it: http://wordpress.org/support/topic/plugin-contact-form-7-ajax-all-works-except-for-send?replies=25
    “Replacing jQuery 1.4.2 with 1.3.2 fixed the problem in WP3.0 for me. Now I’m just waiting for an update of CF7 to work with jQuery 1.4.2. ”

    @takayuki Miyoshi
    even when disabling Javascript according to your suggestion my problems persist:
    the page reloads and shows the green box that says that the message has been sent. However, I receive nothing.

    I am using it the form on a bi-lingual website. On the default language it is working fine. On the other language it is not working.

    Any ideas?

    Thanks.

    Hi – had a problem with the messages not appearing in Contact form 7. Tried the earlier scripts.js which didn’t work for me. I disabled contact form 7 widgets and an ad manager I had and all is working.

    Bodenseepeter

    @bodenseepeter

    I had the same problem with the emails notifications being sent out correctly but the spinner running infinitely, and I am using WP3 and the default theme at http://www.cyclesummit.de/konferenz/anmeldung/

    After I deaktivated all other plugins cf7 worked fine again and showd the green message.

    Thanks Takayuki Miyoshi, excellent plugin!

    itmitra

    @itmitra

    Hey Guys, got one solution [may be patch work]. I don’t have the explanation yet, but try out at your end.

    I have other plug-ins installed along with CF7 [upgraded today to 2.4.2]. I had been facing same problem till today’s update [even after up-gradation].

    I used “File Upload” field in my form, and surprisingly form starts working without any problem. All validation getting done.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: Contact Form 7] error/success messages dont show.’ is closed to new replies.
Skip to toolbar