Support » Plugin: Contact Form 7 » [Plugin: Contact Form 7] [ContactForm7] Infinite loading

  • Hello.

    Last time I’ve installed CF7 and a captcha plugin for this great thing. Everything work fine – I can set up everything without problem, but there is one issue, what is destroying whole plugin.

    When I’m trying to send a email by a CF7, loading icon is infinite. I’ve check out a FAQ, disabled whole plugins, set a default theme, changed language into english. Nothing, still after filling info, and click “Send” (Wyślij in my language), loading icon is loading, loading, loading… Nothing after many minutes.

    I’m using newest version of CF7, newest WordPress 3.0.1, my server have installed whole needed modules, other plugins to send for example newsletter is working fine.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Try disabling permalinks. Then see if it works. Then re-enable permalinks and see if it still works.
    Would help if we could see the page.

    I’ve done this – set up a permalinks into default, try to send email (failed), enamble again my option, try to send again (failed).

    http://mmoblog.pl/redakcja/kontakt/

    Here you go.

    The URL on the submit button is wrong.
    In the Contact form 7 plugins directory open includes/classes.php
    Around line 109 you will see:
    $url = wpcf7_get_request_uri();
    change that line to be:
    $url = ‘/index.php/’.wpcf7_get_request_uri();

    See if that resolves it.

    Its putting /kontact/#wpcf7-xxxxxxxxx
    and it should be like:
    /kontact#wpcf7-xxxxxxxxx

    Yup, that have changed something – now Contact Form is working, but still isn’t working perfect.

    function form_html() {
    form = '<div class="wpcf7" id="' . $this->unit_tag . '">';
    url = '/index.php/'.wpcf7_get_request_uri();
    if ( $frag = strstr( $url, '#' ) )
    $url = substr( $url, 0, -strlen( $frag ) );
    $url .= '#' . $this->unit_tag;

    I’ve found this line between those code lines.

    Now Contact Form shows (in Polish):
    Unable to send your message. Try later or contact authors in other form.

    (without this in code ofc, I just wanted to show this line up)

    Looks like you made a mistake when editing. You are missing the “$” at the begining of the line you changed.
    You have:
    url = '/index.php/'.wpcf7_get_request_uri();
    and it should be:
    $url = '/index.php/'.wpcf7_get_request_uri();

    It’s not changing anything.

    You must have the code really screwed up. You now have double slashes after index.php and still have the slash after kontact.
    Can you post the code again you have so we can take a look?

    Otherwise you might try hardcoding the link:
    $url = ‘/redakcja/kontakt#wpcf7-f1-p5511-o1’;
    or
    $url = ‘/kontakt#wpcf7-f1-p5511-o1’;

    I don’t think that theres any “screwed up” code in my blog cuz I’m not a coder, and I’m not changing anything in files 🙂
    Maybe simply my hoster is a bad company with n00bs in work. However this is simply a WordPress + some plugins and a design made by Rick Noach (Elegant Themes).
    Even I’ve disabled whole plugins, set up a default theme and english language, nothing changed.

    Here is a code from line 50 to 88 (only there was a
    $url = wpcf7_get_request_uri();
    code). Thanks for your time and that you are helping us/me in some problems with this plugin. Hope we will fix this soon 🙂

    `/* Generating Form HTML */
    function form_html() {
    $form = ‘<div class=”wpcf7″ id=”‘ . $this->unit_tag . ‘”>’;
    $url = ‘/redakcja/kontakt#wpcf7-f1-p5511-o1’;
    if ( $frag = strstr( $url, ‘#’ ) )
    $url = substr( $url, 0, -strlen( $frag ) );
    $url .= ‘#’ . $this->unit_tag;
    $url = apply_filters( ‘wpcf7_form_action_url’, $url );
    $enctype = apply_filters( ‘wpcf7_form_enctype’, ” );
    $class = apply_filters( ‘wpcf7_form_class_attr’, ‘wpcf7-form’ );
    $form .= ‘<form action=”‘ . esc_url_raw( $url ) . ‘” method=”post”‘
    . ‘ class=”‘ . esc_attr( $class ) . ‘”‘ . $enctype . ‘>’ . “\n”;
    $form .= ‘<div style=”display: none;”>’ . “\n”;
    $form .= ‘<input type=”hidden” name=”_wpcf7″ value=”‘
    . esc_attr( $this->id ) . ‘” />’ . “\n”;
    $form .= ‘<input type=”hidden” name=”_wpcf7_version” value=”‘
    . esc_attr( WPCF7_VERSION ) . ‘” />’ . “\n”;
    $form .= ‘<input type=”hidden” name=”_wpcf7_unit_tag” value=”‘
    . esc_attr( $this->unit_tag ) . ‘” />’ . “\n”;
    $form .= ‘</div>’ . “\n”;
    $form .= $this->form_elements();
    if ( ! $this->responses_count )
    $form .= $this->form_response_output();
    $form .= ‘</form>’;
    $form .= ‘</div>’;
    return $form;
    }`

    Right now the form looks like its submitting but the wp_mail function is failing. Do your users receive like registration, password reset emails?

    Ya, one of problem is fixed, but next one appears. There was a problem with my wp_mail section, I’ve installed plugin that is changing this wp_mail into a SMTP connection named WP-Mail-SMTP by Collum Mcdonald.

    Now every sending email is working uber cool and mega fast. But new problem appears with Contact Form. Mail is well sended but the loading icon is blinkind infinity.

    So contact form is sending an email now, but theres not any info like “Email sent”. Loading icon is running infinity. Is there a possibility to fix this?

    Let’s go back to basics before getting deeper.
    Disable Plugins.
    Try default theme.
    DIsable Permalinks.

    See if any that has any affect.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Contact Form 7] [ContactForm7] Infinite loading’ is closed to new replies.