Support » Plugins » [Plugin: Contact Form 7] Checkboxes don’t appear in submitted e-mail

  • Plug-in looks and works great with the exception that boxes that are checked in the form on my site do not show up at all in the e-mail that’s sent.

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’m having the same problem.

    Yep, same problem here…

    In Contact Form 7 config, there is a “Mail” section on the right side there is a area called “Message Body”. You will need to build the email message with the info you wish to have sent from the form. Something like that:

    [city-name], [state-name] [zip]
    [phone], [work-phone], [cell-phone]

    The items in brackets are the tag names used in the form. Text can also be added to the email message on a seperate line of between tags names.

    Hope that helps.


    I am using WordPress 2.7.1 with the latest version of Contact Form 7.

    In the left section of the “Form” section, I have defined (albeit with a larger table):

    <p>Type of Service</p>
    <table border="0">
    <td> => Service Category I </td>
    <td> [checkbox TypeOfService "Service1"] </td>
    <td> [checkbox TypeOfService "Service2"] </td>

    In the “Message Body” section of the “Mail” section, I have specified:

    Type(s) of Service: [TypeOfService]

    Yet, the checked boxes are not listed in the email.

    gsiroland: I had the exact same problem. Seems you cant “divide” one checkbox into multiple ones like that. I changed mine like so:

    [checkbox TypeOfService "Service1" "Service2"]

    And then it worked. Another solution (since I wanted to “place” the checkboxes myself) was this:

    [checkbox TypeOfService1 "Service1"]
    [checkbox TypeOfService2 "Service2"]

    ..and then also change the e-mail to:

    Type(s) of Service: [TypeOfService1] [TypeOfService2]

    Hope this helps.

    You should use CSS to style your checkboxes, not table cells.

    I am having trouble getting my checkboxes to show up in my email.

    Here is what I have for the code on the left hand side:

    <p>Your Name (required)<br />
        [text* your-name] </p>
    <p>Your Email (required)<br />
        [email* your-email] </p>
    <p>Sign Me Up For Your Newsletter<br />
        [checkbox Newsletter "Yes" "No Thanks"]</p>
    <p>Your Message<br />
        [textarea your-message] </p>
    <p>[submit "Send"]</p>

    And here is the output in my email:

    [checkbox Newsletter "Yes" "No Thanks"]

    Any ideas?

    @takayukister I have read both of those docs and still can’t figure out how to make my drop down selections automatically show up either in the subject line (where they should go) or in the message body.

    Not so sure what I’m doing wrong, is there other documentation available?


    Wait!! I just figured it out.

    The second word in the tag is its name. For example, the name of [text* your-name] is ‘your-name.’ This name is important as it is used later in your mail template.

    SO, if you’re using the dropdown menu (as I am) and the code in the mail section is:

    [select menu-46 "I need a website and marketing collateral." "I'm interested in copywriting services." "I want to know more about consulting." "I'm launching a business and I have no idea where to start." "I'm not quite sure what I need just yet."]

    Then you would put this in your subject line or message body:


    I don’t know how it works for checkboxes, but I would assume it’s the same concept. Here’s my site if you want to see it in action…


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Contact Form 7] Checkboxes don’t appear in submitted e-mail’ is closed to new replies.