WordPress.org

Forums

Contact Form 7
[resolved] CAPTCHA code displays ok, but msg Your entered code is incorrect always dis (8 posts)

  1. surefire12345
    Member
    Posted 4 years ago #

    No problem with the CAPTCHA code displaying but even when it's entered absolutely correctly (yes I've checked up and lower case and even viewed the image via FTP to double-check), when the form is submitted it still says:

    "Your entered code is incorrect."

    ... even though it is patently correct.

    Here's an example of a page where it won't work: http://www.shapps.com/volunteer/

    Any ideas?

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 4 years ago #

    Read this doc first:
    Why isn’t My AJAX Contact Form Working Correctly?

    Then check if your theme's footer.php contains <?php wp_footer(); ?>

  3. surefire12345
    Member
    Posted 4 years ago #

    So adding the <?php wp_footer(); ?> has definitely helped in that the screen was refreshing before when a form was submitting. Now it smoothly submits via the circular hour glass which is much prettier. So that was AJAX not working previously.

    However, it hasn't actually resolved the main problem which is that the CAPTCHA code error still occurs, though this time a red error box appears without any writing in it.

    Somehow it seems to believe that the correct CAPTCHA code entered isn't correct.

    Any further suggestions?

  4. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 4 years ago #

    What is in the wpcf7_captcha folder? There should be pairs of .png and .php sharing the same prefix number.

  5. surefire12345
    Member
    Posted 4 years ago #

    Aha, only .png in that folder. What next?

  6. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 4 years ago #

    What web server do you use? IIS?

    If you use PHP safe mode, it can cause problems, it should be turned off.

  7. surefire12345
    Member
    Posted 4 years ago #

    Bingo! It's a Linux Plesk server and PHP safe mode was switched on. Switched that off and it works a treat.

    Thanks very much. Donation on its way.

  8. Dana
    Member
    Posted 4 years ago #

    I have to enter the CAPTCHA twice. The first time it says it was entered incorrectly, the second time it works, always. head and footer tags are where they should be. I'm not sure what else the problem could be. I know it has to do with how quickly the form is loading but don't know how to fix it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic