Support » Plugins » [Plugin: Contact Form 7] Blank screen when activating on a nl_NL localized blog

  • Mark

    (@codeispoetry)


    This plugin generates a blank screen in the WP Admin when I activate it on an nl_NL localized blog. The strange thing is that this happens only if the master (blog-wide) nl_NL file is present.

    Thus, to reproduce:
    1. set WPLANG to nl_NL in wp-config.php
    2. observe how Contact Form 7 itself is nicely localized
    3. copy the WordPress-wide nl_NL.mo (any recent version) into wp-content/languages/
    4. WP Admin becomes blank screen

    (5. rename nl_NL.mo to something else to get rid of blank screen)

    Anyone seen this problem? Is it since 2.9.2?

    http://wordpress.org/extend/plugins/contact-form-7/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Where did you download the nl_NL.mo from?

    Mark

    (@codeispoetry)

    From SVN.

    I did a test following your procedure, but I saw no problem. It works correctly.

    Mark

    (@codeispoetry)

    Okay, sanity check: which .mo file did you use?

    I’m a bit mystified myself since I have it happening on one site whereas on another (also running WP2.9.2 and CF7) there is no problem. Yet deactivating all plugins and activating them one by one shows CF7 to be the culprit on the problematic site.

    http://svn.automattic.com/wordpress-i18n/nl/branches/2.9/messages/nl_NL.mo

    Why not ask users in nl_NL locale? I know there are many users in Holland, but I haven’t heard such issue from them.

    Mark

    (@codeispoetry)

    I have asked them; they haven’t seen something like this either. Thanks anyway, I’ll figure it out.

    Mark

    (@codeispoetry)

    Unfortunately, I can reproduce this on another site (2.9.2, CF 2.2) with the above nl_NL.mo. I get a blank screen of death with the following combination:
    1. CF7 activated
    2. sitewide nl_NL.mo used

    As soon as I either (1) deactivate CF7 or (2) rename the sitewide nl_NL.mo or (3) set WP_LANG to ”, the problem goes away.

    Wanna take a look at the site? Does CF7 have a debug mode that could provide more info?

    Do you have sufficient memory?

    Mark

    (@codeispoetry)

    Memory limit is 32M.

    Mark

    (@codeispoetry)

    Okay, I upgraded to 128M and the problem is gone.

    It is less than ideal though that the whole thing fails silently on this — and what’s the deal with requiring more than 32M for localization anyway?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Contact Form 7] Blank screen when activating on a nl_NL localized blog’ is closed to new replies.