WordPress.org

Forums

Contact Form 7
[resolved] Akismet causes CF7 submissions to hang (6 posts)

  1. Rob Marlbrough
    Member
    Posted 2 years ago #

    I am using the great CF7 plugin and if Akismet is enabled, the form submission hangs. I've renamed the fields so that the fields that akismet scans do not exist, but it didn't help. Any ideas?

    I've disabled all other plugins, and using 2011 theme as test, it still hangs.

    I may just switch to Facebook comments and disable Akismet completely.

    http://wordpress.org/extend/plugins/contact-form-7/

  2. n0yes
    Member
    Posted 2 years ago #

    I have the same problem. I checked all the plugins and Akismet is definitaly the cause that submission hangs. I also deleted the Akismet fields in WPCF7, but the problem remains if Akismet is enabled.

    It has something to do with the warning I think:
    '
    <b>Warning</b>: trim() expects parameter 1 to be string, array given in <b>/home/neja/krdelo/wp-content/plugins/contact-form-7/modules/akismet.php</b> on line <b>70</b>

    <b>Warning</b>: trim() expects parameter 1 to be string, array given in <b>/home/neja/krdelo/wp-content/plugins/contact-form-7/modules/akismet.php</b> on line <b>70</b>
    {"mailSent":true,"into":"#wpcf7-f2092-p2619-o1","captcha":null,"message":"Your message was sent. Thank you."}
    '
    I have disabled Akismet for now and started to get spam :(
    I need a solution. Please help.

  3. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    I'm going to release v3.3.1 that fixes the problem. If you don't mind, could you help testing the development version?

  4. Rob Marlbrough
    Member
    Posted 2 years ago #

    I sure will, and will report back. Thanks.

  5. n0yes
    Member
    Posted 2 years ago #

    I also don't mind. Looking forward to the upgrade!

  6. n0yes
    Member
    Posted 2 years ago #

    I checked. Akismet plugin is enabled. I use 2 akismet fields:
    [text* your-name akismet:author]
    [email* your-email akismet:author_email]

    It works fine!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic