Support » Plugins and Hacks » [plugin: Contact Form 7 2.0] Upgrade fails?

  • I just noticed that Contact Form 7 v2.0 was released, and went to upgrade my servers as I make quite extensive use of this plugin (it’s great!).

    Problem is it doesn’t seem to be working. Nothing is displayed on the new ‘edit’ page, and the only thing that displays under the top level is ‘add new’. Is anybody else experiencing this?

Viewing 15 replies - 1 through 15 (of 27 total)
  • I have the same problem. The plugin upgrade seems to have deleted my existing forms (not visible to users either). Creating a new form has no effect — all I see is “add new” even after I save a new form.

    Please fix this!

    Mark

    The good news is that re-installing v1.10 fixes it, so I will stick with that for now. Maybe you should do the same, delayedinsanity.

    Mark

    Note that you need to deactivate a plugin before replacing files. When you re-activate it, Contact Form 7 2.0 creates new table and copy your old data into the table. If you are using automatic plugin upgrade of WordPress, it does all those processes for you.

    I had the same problem today, it was impossible to create a new contact form. If you do not deactivate previous version before update you will get this problem. So I deactivated the plugin, deleted it from server and made a new installation ov version 2.0 – now it’s working as I want.

    @harrism wayyyy ahead of ya haha, I reinstalled the old version immediately following this discovery. I don’t like having broken plugins running on my sites if I can help it.

    @takayukister that makes sense, I’ll run a backup of my database first, then give the update another try and let everybody here know how it goes!

    …seemed to work just fine, didn’t lose my forms, which makes me happy. I do have one question for you though @takayukister, why did you move it to it’s own menu page when there really seems to be no difference between it and the ‘edit’ submenu option? I moved it back to Tools so that it’s still easy to find but nice and tucked away when not in use. 🙂

    @delayedinsanity It’s good to hear that it has gone well.

    The reason why I moved the menu to top level is that its sub menus are going to be added in the future. And I’m thinking of module creators who needs own sub menu under Contact main menu. The release of v2.0 was the best timing for change.

    The 7.2.0 plugin doesn’t work in any way of installation. I reinstalled the old version immediately.
    Using automatic plugin upgrade, doesn’t work.
    Upgrading manually with or without de-activation, doesn’t work, too.

    I have the same problem.

    What version of WordPress are you both running? Worked flawlessly for me the second time when I deactivated the original plugin.

    I use WordPress 2.8.2. On localhost install without problem, but on server upgrade fails. After install I have only “add new” button. If I add new form, after save i have still only button “add new”.
    Old version Contact Form7 working OK.

    Please fix problem.

    What will happen if you deactivate Contact Form 7 and activate it again?

    Deactivate and activate plugin not help. I tried this already.
    I tried also delete files, and install new version contactform7.
    But it is also not solved the problem.

    We’re having the same problem. We are running it on WPMU. We did have it on WPMU 2.7.1 and upgraded to Contact Form 7 2.0 and encountered the problem. We lost all our forms. We reverted back to the old version and they came back.

    Today we upgraded to WPMU 2.8.2 and I tried to see if CF7 2.0 would work, but it still doesn’t. Problem I am having now is We’ve lost our forms AND can’t get the system to revert to the old version of the plugin.

    I have the same problem. I upgraded to CF7 2.0 and all my forms are gone. I used the automatic plugin upgrade of WordPress. (I see the default form when you use it for the first time. So CF7 2.0 made new tables.) Deactivating and deleting CF7 2.0 and installing and activating CF7 1.10 could not save the problem. (Now I see only “add new form”).

    Two months ago I rebuild my site, for test purpose, on my localhost. I noticed the same problem with CF7 1.10. After installing the files and the database, all my forms have been lost. I needed to rebuild them again.

    Unfortunately with WP-table-reloaded, another excellent WordPress plug-in, I had the same experience. All my table have been lost when I rebuilded my site. Today I upgraded there plug-in with the latest version and the same problem re-occurs. Perhaps this info can help you troubleshooting this issue. I’m still using WP 2.8 and the Atahualpa Theme.

    Wbr
    Jan

    @lautrec your story is really curious. Would you tell us more in detail?

    What happens if you once delete Contact Form 7, delete the wp_contact_form_7 table from your database, and install the latest Contact Form 7 again?

    Does your server assigns enough memory for the PHP? Do you use other plugins with them? I ask those because I guess your issue is related to some kind of memory shortage.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[plugin: Contact Form 7 2.0] Upgrade fails?’ is closed to new replies.