WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Connections] template code for the social links?

[Plugin: Connections] template code for the social links?

  • I’ve read all the docs, and searched everywhere, but I cannot find the templatecode to show all the social site links, ‘twitter/facebook’

    kind of like
    entry->getImBlock gets all the Im’s entered.

    also:
    I am using it for our church, so I would like to separate out the positions like:

    pastors:
    user1
    user2
    elders:
    user1
    user2
    deacons:
    user1
    user2

    What I can’t figure out is the code to have it show my category id’s ‘pastors,elders,deacons’

    I started by creating a top level group ‘staff’
    then created subgroups, ‘pastors,elders,deacons’
    I assigned each user to the appropriate group.

    Please advise

    LUVE the plugin btw.. way more than I had ever hoped for!!

    http://wordpress.org/extend/plugins/connections/

Viewing 15 replies - 1 through 15 (of 17 total)
  • shazahm1

    @shazahm1hotmailcom

    @anointed

    Yes, I did overlook adding a tag to display the social media IDs. That will be fix in the next release.

    The ability to show the category id/names will come in the following release. ETA couple months.

    shazahm1@hotmail.com

    Thank you. Boy I really thought I was loosing it there for a min.

    suggestion for future:
    we already have IM, and social but I could really use a generic user created box as well.

    example:
    for my users I would use fields like
    home church:
    denomination:
    etc…

    I do not currently see a way to include custom created fields like that, but then again I may have missed that somewhere as well.

    thnx

    shazahm1

    @shazahm1hotmailcom

    @anointed

    here is a version of the plug-in that includes the missing tag for the social network links. You can download it here:

    http://downloads.wordpress.org/plugin/connections.zip

    Thank you.
    I will download and install it today and report back anything I find.

    I really appreciate the time you spent with me on skype last week and look forward to hearing back from you.

    Unfortunately I can report one pretty major issue with connections that I am having.

    I run buddypress on my sites, and when your plugin is activated I get stuck in the process of trying to create new groups and forums. The really weird part is there are zero server error logs generated, so I have no real clear path to figuring out the conflict.

    If needed, I can setup a demo site running both bp and connections so that you can see what I am talking about if you like.

    For the moment the only solution I have found is to deactivate connections, then go create my bp group, and then reactivate connections. This is definitely not optimal is the concept of bp groups is to allow my users to create their own groups, which would require me permanently deactivating connections, which I don’t want to do as it’s a perfect tool for my needs.

    I’ve documented the issues on the bp forums at:
    http://buddypress.org/forums/topic/group-creation-error-are-you-sure-you-want-to-do-this

    shazahm1

    @shazahm1hotmailcom

    @anointed

    I installed BuddyPress, but unless I’m blind I don’t see any way to create groups. In fact the only menu items I get is a few setup pages located directly under the dashboard link. What am I missing?

    When you visit the groups slug, there should be a button to create a group in the middle of the page.

    Now I use wordpress-mu, have never tried to install buddypress on regular wordpress before as I never had the need.

    Just in case you were not aware.. you do need to activate a buddypress theme. It does come with a default theme that can be activated.

    shazahm1

    @shazahm1hotmailcom

    @anointed

    Sorry I still don’t see anything that shows groups or the ability to create groups. The only thing that I can find that relates to groups is in the activity bar. If I activate the BP theme, no buttons show for creating groups. it only states that no groups can be found. It is the same weather Connections is activated or not.

    Is there any docs at all for BP? Their site doesn’t seem to have any. Can you send a screen capture or link to one? Have a test site?

    @shazahm1

    I am sending the info via skype as there is no pm system here.

    shazahm1

    @shazahm1hotmailcom

    @anointed

    Which plug-in did you install to get the extra steps when creating groups? Right now I have; Details, Settings, Avatar and Invites.

    My test setup is:
    WordPress 3.0 b1
    BuddyPress 1.2.3
    Connections 0.6.2.1

    Here is the one I have installed
    http://wordpress.org/extend/plugins/bp-groupblog/

    I have not yet tested anything with wp 3.0 yet, I personally was waiting until it’s past beta1 before updating any live sites.

    shazahm1

    @shazahm1hotmailcom

    @anointed

    I figured I’d debug with 3.0b1 since WPMU has been merged with WP.

    shazahm1

    @shazahm1hotmailcom

    @anointed

    Ok I’m able to duplicate the error with this setup.

    WordPress 3.0 b1
    BuddyPress 1.2.3
    Connections 0.6.2.1
    BuddyPress Groupblog 1.4.4

    Seems the conflict is actually between the BuddyPress Groupblog and Connections. That should make it easier to narrow down.

    I have no idea why, as I have not touched the connections plugin in some time now, but when I go to add a new connection it says the images saved ok, but error entry could not be added…

    server log shows:
    WordPress database error Query was empty for query made by require_once, require_once, require_once, do_action, call_user_func_array, connectionsLoad->start, connectionsLoad->controllers, processAddEntry, cnEntry->save

    ideas?

    (I did make sure that the lines 90-96 are not commented out from our earlier tries.. so it’s the stock plugin now… )

    hmm turns out it was an error generated when trying to paste in text from word into the description field. Once I removed that and did it by hand it worked

    shazahm1

    @shazahm1hotmailcom

    @anointed

    My dev version fixed an error with the SQL insert. This one should work.

    http://downloads.wordpress.org/plugin/connections.zip

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Connections] template code for the social links?’ is closed to new replies.
Skip to toolbar