Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Plugin conflicts with WP and Media Library access

  • Resolved nakvic

    (@nakvic)


    Sinha,

    the plugin itself works perfectly, however I found to issues:

    1. being activated it prevents at least JetPack to be updated. Somehow WordPress engine is not able to perform updates if Photonic is activated.

    2. Some plugins lost access to Media Library once Photonic is activated. For instance “Slide Anything – Responsive Content / HTML Slider and Carousel” () plugin becomes useless as it is not able to open Media Library.

    Once I deactivate Photonic everything gets back to normal.
    Could you please check out the hooks?

    Regards,
    Victor

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Sayontan

    (@sayontan)

    1. being activated it prevents at least JetPack to be updated. Somehow WordPress engine is not able to perform updates if Photonic is activated.

    Try bumping up the cURL timeout here: Photonic → Settings → Generic Options → Advanced → Increase cURL Timeout. Set it to something like 30.

    2. Some plugins lost access to Media Library once Photonic is activated. For instance “Slide Anything – Responsive Content / HTML Slider and Carousel” () plugin becomes useless as it is not able to open Media Library.

    Photonic does not interfere with the Media library at all, so this is a different type of conflict. On the browser window where you are trying to open the other plugin, can you hit F12, or do a Ctrl + Shift + I, and tell me what you are seeing in the “Console”? Are you seeing any JavaScript errors?

    Thanks for answering.

    1. I set curl, will see if it helps. currently I have no updates to be installed.
    2. Yup. there is a js exception:
    media-views.min.js?ver=5.5.1:2 Uncaught TypeError: Cannot read property ‘limitExceeded’ of undefined
    at initialize (media-views.min.js?ver=5.5.1:2)
    at initialize (media-views.min.js?ver=5.5.1:2)
    at i.h.View (backbone.min.js?ver=1.4.0:2)
    at i.constructor (wp-backbone.min.js?ver=5.5.1:2)
    at i.constructor (media-views.min.js?ver=5.5.1:2)
    at i [as constructor] (backbone.min.js?ver=1.4.0:2)
    at i [as constructor] (backbone.min.js?ver=1.4.0:2)
    at new i (backbone.min.js?ver=1.4.0:2)
    at Object.wp.media (media-models.min.js?ver=5.5.1:2)
    at HTMLAnchorElement.<anonymous> (slide-anything-admin.js?ver=5.5.1:795)
    initialize @ media-views.min.js?ver=5.5.1:2
    initialize @ media-views.min.js?ver=5.5.1:2
    h.View @ backbone.min.js?ver=1.4.0:2
    constructor @ wp-backbone.min.js?ver=5.5.1:2
    constructor @ media-views.min.js?ver=5.5.1:2
    i @ backbone.min.js?ver=1.4.0:2
    i @ backbone.min.js?ver=1.4.0:2
    i @ backbone.min.js?ver=1.4.0:2
    wp.media @ media-models.min.js?ver=5.5.1:2
    (anonymous) @ slide-anything-admin.js?ver=5.5.1:795
    dispatch @ jquery.js?ver=1.12.4-wp:3
    r.handle @ jquery.js?ver=1.12.4-wp:3

    it happens on the following, while wp.Uploader is undefined…

    !wp.Uploader.limitExceeded && wp.Uploader.browser.supported || (this.options.uploader = !1),
    this.options.uploader && (this.uploader = new wp.media.view.UploaderWindow({
    controller: this,
    Regards,
    Victor

    Plugin Author Sayontan

    (@sayontan)

    It looks like the error is being triggered by the “Slide Anything” plugin. Specifically see the 3rd line from the bottom in your error message:

    (anonymous) @ slide-anything-admin.js?ver=5.5.1:795

    There may be something incorrect with the coding of that plugin there, but I cannot say for sure. The reason I suspect a problem with that plugin is because I haven’t seen a JavaScript conflict in the Admin area for Photonic for more than a year now.

    What is your setup? Are you using the Classic Editor or are you using Gutenberg? If you are using the Classic Editor, are you using the “Visual” mode or the “Text” mode?

    If you are using the “Visual” mode of the Classic Editor, you can try Photonic → Settings → Generic Options → Generic Settings → Disable shortcode editing in Visual Editor. You can still add Photonic galleries using the “Add / Edit Photonic Gallery” button, but you will see a “No items found” message in the gallery in your “Visual” mode. You can still switch to the “Text” mode, select the shortcode, and click on “Add / Edit Photonic Gallery” to make edits.

    Sinha,

    I solved 2) with the help of https://github.com/wpmetabox/meta-box/issues/1139 🙂

    The following solved the issue with Slide anything plugin, the In functions.php

    add_action(‘admin_enqueue_scripts’, function() {
    wp_enqueue_media();
    });

    Thanks for such a good plugin! Nice job indeed!
    Missing simple CSS customization, but I can handle this 😉

    Regards,
    Victor

    Plugin Author Sayontan

    (@sayontan)

    Thanks.

    Missing simple CSS customization, but I can handle this

    Yes, this is deliberate, particularly for fonts and colours. To the extent possible Photonic tries to adapt to your theme and to external lightboxes. The only thing for which Photonic generates custom CSS are things like the margins for Justified Grids etc., which typically would not be present in a theme. This helps keep the CSS footprint fairly light.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.