Support » Plugin: All In One WP Security & Firewall » Plugin conflicting with comments

  • I’ve been using All In One for years and love it, however, since the last update, visitors have been unable to comment on my site. I’m trying to figure out the conflict.

    I’ve deactivated every plugin and reactivated, repeatedly it’s All In One that is the cause of the issue. I cannot figure out why.

    What happens is, when someone tries to leave a comment, they can click submit, but then the timer animation runs and runs, and the comment is never actually submitted.

    Is anyone else having this issue? Any suggestions?

    I have the plugin deactivated right now: littleredtarot.com

    Thanks!

    • This topic was modified 1 year, 6 months ago by  Pedalkraft. Reason: to subscribe to replies by email
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, do you have any of the Spam Prevention features enabled? Did you by any chance update your theme lately?

    Thanks!

    No spam features
    Yes I updated my theme (Make)

    • This reply was modified 1 year, 6 months ago by  Pedalkraft.
    Plugin Contributor mbrsolution

    (@mbrsolution)

    Do you think your theme update might have caused this issue since the plugin was working before.

    • This reply was modified 1 year, 6 months ago by  mbrsolution.
    Plugin Author wpsolutions

    (@wpsolutions)

    Another thing to check/test is the firewall rules. Which of the firewall rules do you have active? If any, perform some tests by deactivating all of the rules and if the problem goes away find the rule which is responsible by activating them one by one and testing comments at each rule activation.

    • This reply was modified 1 year, 6 months ago by  wpsolutions.

    Thanks both. I’ll check the firewall rules and if that doesn’t work, I’ll flag the issue with the theme creator.

    Thanks!

    Hello,

    I’ve had exactly the same problem these last 2 weeks (& I haven’t updated my theme). And after de-activating and re-activating all my plugins one by one, it proved to be the All in One WP Security plugin causing conflict.

    On re-activating the All in One WP Security plugin, the Jetpack comments worked again – hurrah – but with a message on my WordPress dashboard from the WP Security plugin saying:

    Would you like All In One WP Security & Firewall to re-insert the security rules in your .htaccess file which were cleared when you deactivated the plugin?

    And when I ticked ‘yes’ the Jetpack comments stopped working.

    So I’ve now de-activated and re-activated All in One again and the Jetpack comments are working, but I’m getting the same question about the security rules in the .htaccess file and want to know if it’s now safe to tick ‘no’?

    I’ve also re-activated all of the firewall settings except “Completely Block Access To XMLRPC” (3 out of 4 settings) and the Jetpack comments are still working…

    But when I checked this in the Spam Prevention:
    “Check this if you want to apply a firewall rule which will block comments originating from spambots” the comments stopped working – so I un-checked it and all is good again 🙂

    So my question is – is it now safe to leave the All in One Security plugin as it is?

    And should I tick ‘No’ to the message I’m getting on my dashboard?

    Thanks,

    Alison https://tarotromance.com/

    Plugin Contributor mbrsolution

    (@mbrsolution)

    (@merrymermaid), yes it is safe to say No to the message you see in your dashboard. And yes it is safe to leave All In One Security plugin as it is.

    Not all rules will work in some website settings and or with some servers.

    Fantastic – thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin conflicting with comments’ is closed to new replies.