WordPress.org

Support

Support » Plugins and Hacks » Plugin conflict: wpDirAuth and WordPress Twitter Bootstrap CSS

Plugin conflict: wpDirAuth and WordPress Twitter Bootstrap CSS

  • wpDirAuth started suddenly running in safemode and I narrowed the conflict down to this code in WordPress Twitter Bootstrap CSS

    /wp-content/plugins/wordpress-bootstrap-css/src/icwp-optionshandler-base.php:

    // Handle any upgrades as necessary (only go near this if it's the admin area)
    		if ( is_admin() ) {
    			require_once( ABSPATH . 'wp-includes/pluggable.php' );
    			if ( current_user_can( 'manage_options' ) ) {
    				$this->updateHandler();
    			}
    		}

    I commented this out and both plugins appear to be working OK now.

Viewing 1 replies (of 1 total)
  • I answered over here but yeah, plugin authors aren’t supposed to load ANY core files because it causes issues and works against the way plugins are supposed to work.

Viewing 1 replies (of 1 total)
  • The topic ‘Plugin conflict: wpDirAuth and WordPress Twitter Bootstrap CSS’ is closed to new replies.
Skip to toolbar