Support » Plugin: Asset CleanUp: Page Speed Booster » Plugin Conflict – Won’t Load Regardless of Plugin Settings

  • Greetings,

    When I activate this plugin, our Instagram plugin stops loaded images.

    I contacted that plugin author, and they said, “The problem is that Asset clean-up plugin minifies our plugin files if you want to use that plugin, then please ask the plugin developers to exclude our plugin files, that way our plugin will work correctly. ”

    I also tried excluding and/or forcing the plugin to load on each page…still won’t work together.

    Any suggestions?

    This is the plugin I’m having a conflict with:

    https://wordpress.org/plugins/wd-instagram-feed/

    Thanks for your time, great plugin!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @horizon70s happy to help you out! Where are the Instagram images usually showing within the page?

    If you have enabled “Minify CSS/JS” feature in Asset CleanUp and for some reason, the minification is not right (although it has been tested countless times, it can happen, you never know), then you can exclude “wd-instagram-feed” plugin files from the minification.

    This conflict is fixable and I will provide a fix as soon as possible. Are you referring to this page: https://reviewyourgear.com/media-page/?

    Hello,

    First off, thanks for the help!

    I did turn the plugin back on, turned off “Minify CSS/JS” feature and it works now.

    However, isn’t that a big part of the plugin? I’d like to use the plugin to it’s full potential.

    Thanks

    BTW, I had to turn the plugin off as it was just causing too many issues (I use the IG plugin on most pages/posts).

    I tried turning it on, and manually allowing it on a test page and it caused more IG issues.

    But I look forward to any advice.

    Plugin Author Gabe Livan

    (@gabelivan)

    @horizon70s I’m glad it works now. It seems there is a minify conflict with the files from “wd-instagram-feed” plugin.

    Until this will be fixed (I need to investigate those files and determine what is actually causing the problem), if you wish to use the “Minify CSS/JS feature”, you have to add the “wd-instagram-feed” CSS/JS to the exception list on the same tab where you enable/disable “Minify CSS/JS”.

    If you find it difficult to apply the changes, let me know and I’ll be happy to assist you 😉 It should be fairly straight forward within the plugin’s settings.

    • This reply was modified 2 months, 2 weeks ago by  Gabe Livan.

    Juuuuuust so we’re on the same page…do I find every call to JS/CSS and add it in there? Is it a server path or URL?

    Maybe just give me one example and I can figure it out from there… 😉

    Thanks!!!

    Plugin Author Gabe Livan

    (@gabelivan)

    @horizon70s Just go to “Minify CSS & JS Files” tab and in the textarea exceptions field, you add the following:

    1) For the CSS
    /wp-content/plugins/wd-instagram-feed/(.*?).css

    2) For the JS
    /wp-content/plugins/wd-instagram-feed/(.*?).js

    Please check out the following print screen: https://prnt.sc/n9goj1

    You can do the same for “Combine CSS & JS Files” if you use that feature and you believe it’s necessary.

    PS: I’ve noticed you’re also using minify CSS/JS files feature from WP Fastest Cache. Try to not use both as it can lead to conflicts and more server resources used. After all, they are doing the same thing.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.