Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Plugin conflict with Custom Post Type UI

  • Resolved bazzablue

    (@bazzablue)


    I have created a custom post type with Custom Post Type UI. I am unable to publish a post in the custom post type. An error box displays with an option to copy error. I have copied the following which refers to NextGen. If I deactivate NextGen Gallery I am able to add and publish custom post types. Please could you advise as I need both of these plugins working.

    Error: An error occurred while running 'mapSelect': Cannot read property 'ngg_post_thumbnail' of undefined
    The error may be correlated with this previous error:
    TypeError: Cannot read property 'ngg_post_thumbnail' of undefined
        at https://mmf.org.uk/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_block/static/build/post-thumbnail.min.js?ver=3.2.21:1:13830
        at Object.current (https://mmf.org.uk/wp-includes/js/dist/data.min.js?ver=4.9.2:1:19491)
        at t (https://mmf.org.uk/wp-includes/js/dist/data.min.js?ver=4.9.2:1:19116)
        at https://mmf.org.uk/wp-includes/js/dist/data.min.js?ver=4.9.2:1:19227
        at Vb (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:104:431)
        at Ti (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:148:85)
        at unstable_runWithPriority (https://mmf.org.uk/wp-includes/js/dist/vendor/react.min.js?ver=16.9.0:26:340)
        at Ma (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:52:280)
        at Ia (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:140:407)
        at ze (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:118:14)
    
    Original stack trace:
        at Tt (https://mmf.org.uk/wp-includes/js/dist/data.min.js?ver=4.9.2:1:18925)
        at https://mmf.org.uk/wp-includes/js/dist/data.min.js?ver=4.9.2:1:19466
        at je (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:78:476)
        at qe (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:89:115)
        at ph (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:216:489)
        at lh (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:126:409)
        at O (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:121:71)
        at ze (https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:118:14)
        at https://mmf.org.uk/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:53:49
        at unstable_runWithPriority (https://mmf.org.uk/wp-includes/js/dist/vendor/react.min.js?ver=16.9.0:26:340)
    • This topic was modified 1 month, 3 weeks ago by Steve Stern.
    • This topic was modified 1 month, 3 weeks ago by Steve Stern.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @bazzablue,

    We are sorry for the inconveniences. There is a known conflict between the custom posts and NextGen Gallery’s “featured image”.

    We really hope to see this one solved in the future updates but in the meantime, the only solution will be temporarily deactivating NextGen Gallery plugin during the custom posts’ creation or editing process.

    Ok. Thanks for letting me know.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.