Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Plugin conflict due to old version 2.9995 of jquery-cycle

  • I’ve got the current versions of NextGEN Gallery plugin, Meteor Slider plugon, and WordPress installed (version numbers below).

    The Visual Editor breaks, with a “ReferenceError: switchEditors is not defined” JavaScript error – which is fixed if I disable either of the NextGEN pr Meteor plugins. The error exhibits as the Visual Editor pane displaying blank, and the Visual/Text tabs doing nothing when clicked – the javascript console displays the ReferenceError above when attempting to switch tabs/modes.

    It looks like the jquery-cycle include is the problem, because if I comment the “wp_register_script(‘jquery-cycle’ … ‘2.9995’)” line out in the NextGEN plugin (leaving the version 3.5.1 of jquery-cycle imported by Meteor), everything appears to work as expected.

    Is there some reason NextGEN uses 2.9995? Is there unexpected or perhaps just untested behaviour if I use 3.5.1 instead? Is there some way to avoid NextGEN trying to load an old version of hquery components when another plugin has already loaded a newer one?

    – WordPress up to date? WordPress 3.5.1.
    – NextGEN up to date? Version 1.9.12
    – What version of NextGEN Gallery did you upgrade from? (i.e. I had 1.9.8, then upgraded to 1.9.12) Not applicable

    (please confirm the following, with your server host tech) :
    – MySQL up to date (at least 5.2.4)? MySQL version 5.5.30-cll
    – PHP up to date (at least 5.0)? PHP version 5.3.17
    – The mod_rewrite Apache module activated? Yes
    – PHP Safe Mode OFF? Yes

    Additional information that will help us find a solution:
    – Who are you hosted with? CLOUDLINUX 6.3 x86_64 vmware WHM 11.36.0 (build 14)
    – What theme are you running? Responsive (ThemeID) – with child theme.
    – Which plugins do you have installed and activated? – Meteor Slides Version 1.5.1 is the plugin that seems to conflict (disabling either that or NextGEN fixes the Visual Editor javascript error). Ful list of plugions: Advanced Custom Field Widget,Akismet,All in One SEO Pack,Contact Form 7,Meteor Slides,NextGEN Gallery,TW Recent Posts Widget,Widget Shortcode,WP Help
    – Does this error still occur if you switch your theme to the WP default, and deactivate all plugins except NextGEN Gallery? (*be sure to clear your browser cache and reload your site after deactivating) No. Error solved by disabling either NextGEN or Meteor.

Viewing 3 replies - 1 through 3 (of 3 total)
  • hi bigiaim,

    any findings on the issue … ?
    im having the blank ( white html text on white bg) visual Editor and nearly the same set up but with less plugins : for me it works if I either deactivate the NGG or the Contact Form 7 plugIn … but would love to use them together


    if I comment the “wp_register_script(‘jquery-cycle’ … ‘2.9995’)”

    has no effect on my situation :

    NGG 1.9.12 and Contact Form 7 version 3.3.3 conflict breaks visual editor

    hi , found out the solution :
    on the virtual server you need 64 Mb Php memory to run NexrGengallery and ContactForm 7 and tinymce together – if you have less tinymce would not load because of a lack of available memory

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Plugin conflict due to old version 2.9995 of jquery-cycle’ is closed to new replies.