Support » Plugin: Flexible Elementor Panel » Plugin conflict

  • Resolved Shamim Hasan

    (@shamim51)


    Hi @webmatpro
    I am author of Front End PM.
    There is a conflict between that plugin and this plugin in FEP_Admin_Settings class. As your plugin use namespace in other files, can you add namespace in this file also so that both your and my plugin can be used in same website?

    Best Regards
    Shamim

Viewing 4 replies - 1 through 4 (of 4 total)
  • Just my thought, but it appears that your namespace is not complete to match the name, and it would make more sense to change yours to match the name of your plugin. ie, FEPM_Admin_Settings. Flexible Elementor Panel matches the name of the plugin already.

    • This reply was modified 5 months, 3 weeks ago by ocbroadband.
    Plugin Author WebMat

    (@webmatpro)

    Hi @shamim51,

    i follow the think of mister @ocbroadband (thanks mate), can you change your name class like this ?

    I will add too a class checking before run it for a better user experience.

    Thanks to you, tell me if everything its right for you.

    • This reply was modified 5 months, 3 weeks ago by WebMat.

    Thank you @webmatpro for replying.
    It seems your plugin is already using namespace in other files eg. https://plugins.trac.wordpress.org/browser/flexible-elementor-panel/trunk/admin/admin.php#L3
    You can add namespace in settings.php file also and that will solve all conflict. No need to change class names.

    As my plugin does not use namespace and all classes/functions are prefixed with FEP it will be very difficult for me to change that plugin prefix and that will break all hooks as well.

    Plugin Author WebMat

    (@webmatpro)

    Hi,

    the last update 2.1.2 solve it.

    Thanks Shamim and ocbroadband 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.