• Resolved feelinfae


    I have Better WP Security, W3 Total Cache and Add Link to Facebook on my site. Up until February 2013 these plugins got along just fine (for almost 2 years).

    As the plugin Add Link To Facebook is affected I contacted the developer of this plugin first. Here’s the conversation:

    My Post:
    I found out this plugin was not working since Feb. I had removed user id=1 around that time and assumed that was the issue, so I updated the plugin as instructed. Was able to finally get the plugin authorized (see below) however it appears that the Add Link to Facebook will not post to my wall with 2 specific plugins activated:

    1) it would not authorize when the plugins ‘Better WP Security’ and ‘W3 Total Cache’ were activated. I’d go through the FB questions and it would appear to get stuck and sit on a blank page. I got it to work when I deactivated both these plugins; then it authorized fast and easy.

    2) My posts do not show up on the Facebook page when I have these same plugins activated. I have to deactivate both these plugins for a post to show up on Facebook.

    In both instances, I tried with one vs. the other but it appears that it needs to be both deactivated for a post to work.

    Thoughts, suggestions to fix this issue?


    (I do have the FB dev app set to the July settings if that makes any difference)

    From my experience there is a bigger chance that there is a problem in one of the other plugins than in Add Link to Facebook, so first seek help for the other plugins. I have waste my time too many times into looking into problems caused by other plugins. Nine out of time times it is not a problem in Add Link to Facebook and the problem could not be fixed in Add Link to Facebook too.

    Any thoughts? Is this a WP Security issue? Also posting on W3 Total Cache support page.



Viewing 5 replies - 1 through 5 (of 5 total)
  • Looks like it was a conflict with Better WP Security. Their latest update fixed the issue.

    It hasn’t for me, can you tell me what you mean by

    so I updated the plugin as instructed.

    As I am in the same position as you.


    Hi Colinsp,

    I followed the FAQ’s the dev posted on his plugin page:
    He also recommends going to his forum for further support.
    I think the FAQ areas you want to look at are U20/U21/U22

    He has a lot of info there but there is a bit of code you need to add to one of the PHP pages in order reset the “Share with all Users” option. I first did this via the WP admin editor and it broke the site (with a simple copy/paste). So I then did it manually via FTP and it worked. I’m thinking this is the part you are referring to? I also had to sign into facebook and update the dev app to July 2013 criteria settings. Feb is when FB changed its dev stuff and that’s when this plugin stopped working (from what I can make out via my client’s page).

    Now that WP Better security is updated, I’d assume you wouldn’t have to deal with the re-authorization issues I did.. but if it does cause issues for you, you may have to deactivate the security and cache plugin for it to work.

    Hope that helps you!

    Thanks for your reply. I am still having issues because of the id=1 tied to Add link to Facebook. I created a new admin user and manually assigned it the ID of 1 and then logged in as that user and reauthorised the plug-in. Hopefully that will have sorted it. I will try a new post later to see if it works.

    IMHO it is stupid tying the plugin to a particular user id instead of role.

    IMHO it is stupid tying the plugin to a particular user id instead of role.

    100% agree

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin Conflict?’ is closed to new replies.