Support » Plugin: Comprehensive Google Map Plugin » [Plugin: Comprehensive Google Map Plugin] KML file not loading, maps not displaying as expected

  • Resolved lydiamann592

    (@lydiamann592)


    I assume there is a jQuery conflict keeping my map from loading with the KML file associated, but I am out of ideas for resolving it.

    I’ve followed the KML samples for generating my file “ya-GoogleMap.kml” and linked to it on the first map on this page:
    http://www.yogaanatomy.org/staging/countries/
    The second map on that page is an attempt using the “Location” field – not a workable solution since there are too many points, with more to come.

    I’ll be happy to donate to support your development, if I can get the plugin working correctly, so I’m hopeful you’ll be able to help me solve this.

    http://wordpress.org/extend/plugins/comprehensive-google-map-plugin/

Viewing 5 replies - 16 through 20 (of 20 total)
  • Thread Starter lydiamann592

    (@lydiamann592)

    @mmaga I was never able to resolve this, just gave up. I’m hoping your new post attracts attention of someone who can assist.

    Hey lydiamann592, last night i tried something else and it kinda worked.
    this is what i did: i created a map in maps.google.com, downloaded the kml, opened in the editor and deleted all the <Style id = “StyleN”> and added instead

    <Style id = "anotherStyle">
         <IconStyle>
            <Icon><href>http://maps.google.com/mapfiles/kml/shapes/airports.png</href></Icon>
         </IconStyle>
     </Style>

    at the begining, right after:

    <Document>
      <name>grand canyon</name>
      <description><![CDATA[]]></description>

    (it’s the google maps airport icon)
    and then, i added

    <styleUrl>#anotherStyle</styleUrl>

    to each Placemark, in my case it looked like:

    <Placemark>
            <name>Day 11 - Mile 167 </name>
        <atom:link href="http://www.flickr.com/photos/30071120@N02/8010497184/" rel="related"/>
        <description><![CDATA[<p><a href="http://www.flickr.com/people/30071120@N02/" target="_blank">mmaga</a> posted a photo:</p>
    <p><a href="http://www.flickr.com/photos/30071120@N02/8010497184/" title="Day 11 - Mile 167 - Waterfalls after a Monsoon at National Canyon" target="_blank"><img src="http://farm9.staticflickr.com/8181/8010497184_86e2d8420a_m.jpg" width="240" height="159" alt="Day 11 - Mile 167 - Waterfalls after a Monsoon at National Canyon"></a></p>]]></description>
        <styleUrl>#Alternate_style</styleUrl>
        <Point>
          <coordinates>-112.892929,36.257389,0.000000</coordinates>
        </Point>
      </Placemark>
      <Placemark>

    let me know if it works for you. It’s not the most efficient way… but at least i could see the placemarks!
    I’d like to know if there is another thing we can try… Maybe alexanderzagniotov can help us? I loved the plugin and I hope we can find a work around to be able to use it!

    Hey @lydiamann592, i’m back working with the plugin and it didn’t work for me, so i ran a validation with:
    http://www.kmlvalidator.com/validate.htm
    it turned out that the kml output from google maps had a lot of errors. so i had to delete some of the tags (i don’t know enough to edit or troubleshoot it) until i had no errors. and then it worked.

    there’s another plugin geo mash up. it’s very similar. have you tried it?

    Afraid I gave up on this plugin and went for one where the place marks have to be added manually. Suspect I was also using dodgy KML, from GoogleEarth. Will keep an eye on this thread though, just in case.

    Thread Starter lydiamann592

    (@lydiamann592)

    Thank you @mmaga for your input. I’ll look into Geo mash up.
    @mkgees: can you post the name of the manual add plugin?

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘[Plugin: Comprehensive Google Map Plugin] KML file not loading, maps not displaying as expected’ is closed to new replies.