Support » Plugins and Hacks » [Resolved] [Plugin: Collapsing Categories] Collapsing archives don't collapse

[Resolved] [Plugin: Collapsing Categories] Collapsing archives don't collapse

  • Plug-in worked fine for years, and I do not know when it stopped working, as I rarely click on my own archives. Though I could guess this started after the 3.4 upgrade.

    The list does not expand and contract when you click on a month. Before, it would list all the post titles. Now if I click on a month, it just links to a page of all the posts from that month. If I click on a previous year, it goes to a feed of all the posts from that year.

    It is my preference, and this is how the plug-in worked before, that you click on a month or year and the list expands and you can click on a specific post from the list.

    Haven’t seen anyone else having this problem recently, and other forum messages don’t seem to resolve my problem.

    Any ideas? Thanks if you can help. I’ve had no problems with this plug-in at all, until now.



Viewing 13 replies - 1 through 13 (of 13 total)
  • Something else to note, that I attempted to go to the “options and settings” link for this plug-in, on the WP plug-in page, and it gave me an error message: “You do not have sufficient permission to access this page.” I’m not sure why I wouldn’t have permission, as I’m the owner/administrator. As well, I attempted to download another archives plug-in, just to try that, and it gave me the attached error message.

    Fatal error: Cannot redeclare collapsarch_load_domain()(previously declared in /home/mydirectory here/public-html/myblognamehere/wpcontent/plugins/collapsing-archives/collapsArch.php:34) in ……. etc on line 39.

    Is this an issue with my blog or with the plug-in?

    Alright I’m not sure what happened, except perhaps a small change I made in the plug-in set up, when I checked on the problem, has now registered and the archives are collapsing more elegantly than ever before. So, um, never mind.

    Although the problem seemed to repair itself yesterday, now it is once again NOT cascading but doing as I mentioned above, just clicking to the full page of posts for an entire month or year, depending on what you link to.

    Any ideas how to restore my collapsing archives? I’ve checked it in three different browsers, it doesn’t work in any of them now.

    I’m experiencing this issue as well. I think it has to do with the upgrade to 3.4 because it was working great in 3.3 before I upgraded a couple days ago.

    I think it is related to the upgrade, as mine worked fine, as far as I know, until last week when I upgraded. Do you think there’ll be an updated Plug-in? To whose attention should we bring this issue? WordPress or the Plug-in creator?

    I started a thread as well and the developer of the plugin responded in it. This is a developer issue, not a WordPress one I think. He expressed interest in seeing the issue so I bet the plugin will be fixed eventually.

    I added to your thread SundaramDesign as the collapsing categories fail to work properly on my site’s home page.

    Great, Renee! I saw your reply and that is really weird how it works on some pages of your site and not on others. I hope it gets fixed because it’s a very useful plugin. I found the dev’s email on his blog and emailed him a link to the page on my site with it and a screenshot of the settings I had so he could see what was happening. We’ll see…

    Ok, update here. The developer was kind enough to respond to my email and he pointed out jQuery was not being called on my site. I guess I had always had some plugin that put that in for me in previous builds and that wasn’t the case on the current site I’m working on. Anyway, the plugin worked like a charm once I got the jQuery call up in the header.

    Brilliant. So easy and it works now. Thanks for finding the solution and for sharing it.

    Yeah, WordPress 3.4 must handle scripts differently or something. Perhaps 3.3 and below would inject jQuery by default and they removed that in 3.4. Regardless, it seems like that’s all it was (for my issue) so back to business!

    I am having trouble with this too (I’ve just installed it). I’m working on a site locally so can’t link to it. However, with regards to the possible problem outlined in this thread, I do have this jQuery call being made on my site:

    <script type=’text/javascript’ src=’http://localhost/xxx/wp-includes/js/jquery/jquery.js?ver=1.7.2′></script>

    I don’t know if I need to make some other call elsewhere too? Or perhaps I’ve got a problem elsewhere, like in the CSS?

    I’m also getting the “You do not have sufficient permissions to access this page.” error in the plugin settings page.

    Anyone have any ideas?


    I would have expected that the latest version of WordPress and Subscribe2 (both have been updated since I had this issue last month) would have handled this. I’m sorry that I don’t know more about jquery and scripts to help you. I can tell you the plug-in I installed that resolved the problem for me:

    jQuery Vertical Accordion Menu

    Good luck.


Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] [Plugin: Collapsing Categories] Collapsing archives don't collapse’ is closed to new replies.