Support » Plugin: Codestyling Localization » [Plugin: Codestyling Localization] The plugin broke my site!

  • Resolved Techload

    (@techload)


    Hi,
    I got this error that won’t go away even after disabling the plugin. And it breaks the site completelly when viewed in IE:

    Warning: fread() [function.fread]: Length parameter must be greater than 0 in /home/techl683/public_html/wp-includes/pomo/streams.php on line 113

    Warning: fread() [function.fread]: Length parameter must be greater than 0 in /home/techl683/public_html/wp-includes/pomo/streams.php on line 113

    Please, help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Bit of googling helps..

    I saw a note somewhere about it being due to empty .po files.
    The suggestion was to delete the po files in question.

    also see
    this
    http://www.code-styling.de/english/development/wordpress-plugin-codestyling-localization-en

    search the page for

    wp-includes/pomo/streams.php on line 113

    and see response

    For me was only occuring on one language.
    I entered a translation for one field and the regenerated the .mo file.
    Problme solved.

    Thanks for great localisation plugin!

    Plugin Author codestyling

    (@codestyling)

    This has been solved with version 1.99.8 of this plugin.
    Reason of error: The plugins did generate a *.mo file on an empty catalog.
    Empty catalog means, that there are no translations at all. But the fix doesn’t solve the situation while having “damaged” *.mo files. Please delete the affected *.mo files first.

    Fix: You will get now an error message while trying to create empty *.mo files. So please translate at least one entry to be able to produce a valid mo-file.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Codestyling Localization] The plugin broke my site!’ is closed to new replies.