Co-Authors Plus
Separator not showing with Co Authors Plus (6 posts)

  1. fabusdr
    Posted 4 years ago #

    I'm using the amazing Co Authors Plus plugin.
    On my site I list the authors with

    <?php if(function_exists('coauthors_posts_links')) coauthors_posts_links(' &bull; ',''); else the_author_posts_link(); ?>

    When testing the theme on locale with lampp everything works like a charm and I get something like "author1 • author2 • author3".

    But on the live version (with exactly the same coden lugin and wp version) there is no separator "author1 author2 author3"
    I tried several other separators, like ", " but no chance.

    Any idea? What could I do?
    thank you so much


  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 4 years ago #

    Maybe you tried one of the previous methods to support custom inbetween characters?


    What other differences exist between staging and production? Does the problem persist with all other plugins deactivated?

  3. fabusdr
    Posted 4 years ago #

    Hi Daniel,
    thank you for your answer, I'll try one of the previous option. I just noticed a weird behavior: on the live site the separator is showing only on certain posts.
    Here you have the separator:
    here no separator:
    It's really strange because the two pages are generated by the same template file.
    I'll try what you suggested and let you know.
    Thank you very much

  4. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 4 years ago #

    Oh, I see what you're talking about. Does it always break when there are just two authors? If so, can you try setting the betweenLast argument?

  5. fabusdr
    Posted 4 years ago #

    Thank you Daniel!
    You are right, it seems to break when there are 2 authors but it works for more than 2.
    I tried to add define('COAUTHORS_DEFAULT_BETWEEN', '*') or to add a betweenLast argument, but it does not solve the problem.
    It's difficult to say what changes between the live and local version. I'll try to install all the plugins I have on the live version and tell you if I'm able to find a conflict.
    Again, thank you very much!

  6. fabusdr
    Posted 4 years ago #

    No luck, I made a tar of all my plugin folder in the live site, downloaded it to make sure I have exactly the same version of everything. Then I activated all the plugins on the local version of the site and the separator is still showing. So I guess it's not a plugin conflict.
    I really don't know what can cause the problem, and why it works with more than 2 authors.
    Thank you very much for your help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Co-Authors Plus
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic