WordPress.org

Support

Support » Plugins and Hacks » Co-Authors Plus » [Resolved] [Plugin: Co-Authors Plus] 2.6 not working with WP 3.3

[Resolved] [Plugin: Co-Authors Plus] 2.6 not working with WP 3.3

  • When I save an article by another author, the co-author box clears of contents. When I try to add the author back in still comes back blank (author doesn’t save).

    I just updated a bunch of posts without realizing this and it shows me (when displaying the post in the theme) as the author of them all.

    It won’t let me set it to another author. Tested in FF and Chrome. Please help.

    http://wordpress.org/extend/plugins/co-authors-plus/

Viewing 15 replies - 1 through 15 (of 31 total)
  • Plugin Author Daniel Bachhuber

    @danielbachhuber

    Hand Built

    What other plugins do you have installed? Does the auto-suggest work and allow you to select authors? Also, can you share screenshots of before and after?

    Advanced Access Manager, Advanced Custom Fields, Akismet, CloudFlare, Co-Authors Plus, Contact Form 7, Custom Post Type UI, Digg Digg, Disqus Comment System, Edit Flow, Enable Media Replace, Google Analytics for WordPress, Redirection, Simple Pull Quote, W3 Total Cache, WordPress SEO, WP-DBManager — all latest versions

    Yes, auto-suggest works fine and I can select the author. It just doesn’t save when I save the post–comes back blank.

    before and after saving:
    http://www.brianswebstudio.com/wp-content/uploads/2011/12/before.png
    http://www.brianswebstudio.com/wp-content/uploads/2011/12/after.png

    Thanks

    Plugin Author Daniel Bachhuber

    @danielbachhuber

    Hand Built

    Odd, that’s a server error in the after shot.

    Can you disable all of your plugins except Co-Authors Plus and see if the problem persists? If it doesn’t, try re-enabling one by one to see which is causing the conflict

    I disabled all plugins, but Co-Authors Plus, tried to save a name, came back blank.

    I disabled Co-Authors Plus (so no plugins enabled), saved the article under correct article, it worked (default wp author select). Then I re-enabled co-authors plus and it shows up blank again.

    Plugin Author Daniel Bachhuber

    @danielbachhuber

    Hand Built

    Ok, thanks. For now, I’d recommend downgrading to v2.5.3. If the problem still persists, then there’s another issue at hand. I can take a deeper look soon.

    Plugin Author Daniel Bachhuber

    @danielbachhuber

    Hand Built

    Odd, that’s a server error in the after shot.

    My bad, it was actually a server error I saw 🙂 I’m not able to reproduce the issue, so I’d be interested in any other details you might be able to include, or whether other users experience the same issue.

    I also am experiencing this issue. When I save or publish an article written by someone else, the author is being completely removed and I cannot re-add the author. Regretfully disabling this plugin for now.

    Plugin Author Daniel Bachhuber

    @danielbachhuber

    Hand Built

    @evanw Can you help diagnose? In particular, what plugins do you have installed, and does the problem persist after you disable them?

    Same problem here. It happens only with some users and also with old posts. The user disappears but the posts are still assigned to it.

    If I create a new author and delete the old one reassigning the posts the author shows up again.

    This happens randomly with users that were working fine.
    Downgrade doesn’t help.

    Thank you for the support.

    Plugin Author Daniel Bachhuber

    @danielbachhuber

    Hand Built

    Thanks for your detailed report annoiato. I suspect I might know what’s going on. I’ll test further and report back.

    Same problem here. For a short-term solution I’ve found that it’s possible to edit the author ID number in the posts database, and that will cause it to show the correct author on posts, though it’s still blank in the WP dashboard. Though not a solution for many people as they may not know how or be comfortable with editing the database.

    We’re getting an error when saving saving posts.

    We suspect it has to do with permission levels of the authors.

    We had two authors with the same first & last name (but different usernames), and the one with a lower permission level (but higher id#) wouldn’t save.

    After saving it, the article was instead showing the name of the person logged in (who was entering the articles). The editor showed no name where the author would be.

    When we used the name of the author with higher permission level (and lower id#), it saved fine.

    Though, we had another article with a new author (low permission level) and he saved fine.

    Does it have to do with:

    // Bail on revisions
    if( $data[‘post_type’] == ‘revision’ )
    return $data;

    Should it also check if it’s status = published ?

    (I’m jewishpress’ developer)

    I found that users with a dot in login name are filtered by sanitize_key that’s why it happens only with some users.

    And we have user names with spaces in them (and others with dots) that we imported from another system.
    And that might to be connected to the problem.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Resolved] [Plugin: Co-Authors Plus] 2.6 not working with WP 3.3’ is closed to new replies.
Skip to toolbar