Support » Plugins and Hacks » [Plugin: CMS Tree Page View] Latest update (Version 0.8.8) not working

[Plugin: CMS Tree Page View] Latest update (Version 0.8.8) not working

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same problem, do you happen to use the IM8 Exclude Pages plugin?

    I found that these two plugins conflict when there is an excluded page with a menu order of 0 (zero). Here is the workaround:

    Add this code to your theme’s functions.php file:

    function cms_page_tree_im8_exclude_workaround() {
        global $im8_exclude;
        remove_filter('get_pages', array($im8_exclude, 'exclude'));
    add_action('pages_page_cms-tpv-page-page', 'cms_page_tree_im8_exclude_workaround', 0);
    add_action('wp_ajax_cms_tpv_get_childs', 'cms_page_tree_im8_exclude_workaround', 0);

    You could alternatively hack the core plugin files, but that would be overwritten after the next update.

    I am having the same problem but I do not have the IE8Exclude plugin installed.

    I had the same problem: had the “loading” circle in Google Chrome (although it still worked in FireFox and Safari).

    So I cleaned my cookies in Google Chrome (Preferences > Under the hood > Clear browsing data) and it works again…

    Strange 😉

    Using latest Firefox and at first install it worked great but then I moved a couple of pages and that was the end of it.

    mvergotte – thanks for that info. That worked for me.

    This is a great plugin, but it seems to me that it needs a spring cleaning. I’ve experienced some strange bugs on a new install with this one as the only installed plugin – generally it seems a bit unstable: i.e. new page order not saved, endlessly spinning wheel. Also I have debug turned on, and it returns a lot of warnings and ‘headers not send’ if you change the settings.

    Fantastic plugin — but I am having a few issues with the latest install.
    1. The “endless spinning wheel” does plague me. Deleting cookies for “js_tree” (I think there were 2 different ones) makes the problem go away until I change something (add / move a page.)

    2. Not certain, but I >think< Post / Page revisions are showing up in the tree. They will show up under their main post, and be listed as “INHERIT” in the tree view.

    Thanks again!

    I have the same problem and I would note that several of the most recent posts mention it. (I posted the problem a couple of weeks ago as well We changed browsers and reinstalled the plugin and its still not working…It was a great plugin when it worked but this problem renders it useless to us unfortunately..

    I’ve posted a potential solution to this endless loading problem. Since applying the change, I haven’t had any problems, but I haven’t done much testing.

    Check it out if interested.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: CMS Tree Page View] Latest update (Version 0.8.8) not working’ is closed to new replies.