Support » Plugin: CMS Tree Page View » [Plugin: CMS Tree Page View] Critical Bug: Plugin breaks editing of already saved/published posts/pa

  • I really like this plugin, but I had to deactivate it.

    I recently noticed that when I tried to edit an already published post/page, or even an unpublished post/page that had been saved or auto-saved as a draft (then you exit the editor and later come back to edit again), that many of the text fields would not accept any keyboard entry. The affected fields include, but may not be limited to, the title, the url slug, the text area when set to the html tab (but not when set to the visual tab), the Simple Tags plugin field, the scheduling/published-on date/time fields.

    For some reason this problem does not affect freshly started new pages or posts. But as I said, once a post or page has been published, or saved, then when you go back to edit it the problem arises.

    So I went through my plugins, deactivating them one by one until the problem went away. It was the deactivation of this plugin that caused the problem to disappear.

    I can’t use this plugin until this bug is fixed.

    I’m running WordPress 3.0 with the Thesis 1.7 theme.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Pär Thernström


    Thank you very much for the bug report. I can however not reproduce this bug myself. If anyone else out there is having the problem, please let me know!

    Can you possible give me some more info about your setup, like what browser and OS you are using, and also if you had any other plugins running (I know you deactivated some plugins, but did you have any left enabled?).

    I ran into the same problem on Windows 7 and Ubuntu 10.04. I mainly use Google’s Chrome browser, but I think I ran into the same problem with Firefox as well.

    I have a lot of plugins installed. I had disabled a bunch, but still have quite a few others activated when I discovered that deactivating this plugin solved the problem. I’ll have to try get back to you on which I had deactivated and which activated. I don’t remember precisely.

    I am having the same exact problem. I am using Vista, Firefox (though I had the same issue on IE and a Mac), and WordPress 3.0. I have a lot of plugins installed. You can see which plugins I am using at

    Plugin Author Pär Thernström


    @slewwho thanks for the plugin-list. Gonna install them one after one and see if I end up having the same problem.

    I just deactivated all of my plugins except for CMS Page Tree View and it still shows the same symptoms. When the plugin is enabled, I am unable to edit in HTML mode, but have no problem in Visual mode. Once I deactivate the plugin, the problem goes away.

    My theory is that the problem started with WP 3.0, but I don’t know for sure. It’s possible I just didn’t notice it before since I haven’t had the plugin for very long.

    Plugin Author Pär Thernström


    Can you give me some more details; can you for example focus the text fields, but then nothing happens when you press chars on your keyboard?
    Does none of the fields in the post edit screen work, or is it just some of them that stops working?

    I just can’t figure out what’s causing this.. :/

    Yes, when the plugin is activated you can focus the text fields, but then nothing happens when you press chars on the keyboard. This is true for all fields on the page – edit, title, tags, etc. The only one that seems to work is the Visual field. When I deactivate the plugin, everything works again.

    Plugin Author Pär Thernström


    Hi again everyone. Just wanna let you know that I know what’s causing this problem now. I’m not sure that I can fix it, but I’ll will of course try to fix it. Stay tuned, and thank you for your patience.

    Another post asking for the same issue.

    Seems that even deactivating all plugins, this issue remains.

    Using a Thematic child theme. Thank you Pär.

    Plugin Author Pär Thernström


    Wow, I solved it 7 months ago! 😉 Anyway…can’t remember what it was then and I don’t know if it’s a similar problem this time. But thanks for all bug reports, they are helping. Still a bit of a problem to fix this since I can reproduce this. Will try a bit more in all browsers I can find…

    Pär, I’m really sorry… 🙁

    I have activated debug mode, no warnings at all.

    Also deactivated all plugins, only activated CMS Tree Page View and the same.

    Posts and articles don’t work BUT my custom post type is not afected!! :-O They are working fine.

    Plugin Author Pär Thernström


    Any chance I can get access to you installation, so I can try it out and see for myself. If this is possible you can send more info to:

    Thank you, email sent. 🙂

    Plugin Author Pär Thernström


    Thanks @tradiart! I actually think I found the cause of this: it’s the keyboard shortcuts that can be enabled for a user (to moderate and browser comments).

    Can you who have problems try to disable keyboard shortcuts and tell me if it made any difference?

    Thanks a lot!

    (From the codex: “Keyboard shortcuts are enabled on a per-user setting, and can be turned on by visiting the Profile panel in Administration > Users > Your Profile.”)

    Thank you Pär!

    I have deactivated keyboard shortcuts and now works perfect!! Posts, pages and custom post types can be edited from code directly.

    I have just make a little donation 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: CMS Tree Page View] Critical Bug: Plugin breaks editing of already saved/published posts/pa’ is closed to new replies.