Support » Plugins and Hacks » Client Status » [Plugin: Client Status] Error log messages

  • Resolved WebEndev

    (@munman)


    I recently noticed that my error_log file in the site root was huge. I discovered that it was basically the same three messages, repeating over and over again (see below).

    What’s up with this?

    [16-Aug-2011 11:57:55] PHP Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /home/munman61/public_html/wp-content/plugins/client-status/client-status.php on line 383
    [16-Aug-2011 11:57:55] PHP Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 1: parser error : EntityRef: expecting ‘;’ in /home/munman61/public_html/wp-content/plugins/client-status/client-status.php on line 383
    [16-Aug-2011 11:57:55] PHP Warning: simplexml_load_string() [function.simplexml-load-string]: t1=_blank&bc1=F5EFD8&IS2=1&bg1=F5EFD8&fc1=000000&lc1=0000FF&t=cherylshirema-20&o in /home/munman61/public_html/wp-content/plugins/client-status/client-status.php on line 383

    http://wordpress.org/extend/plugins/client-status/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author ericjuden

    (@ericjuden)


    My guess is that you have WP_DEBUG enabled on one of your servers and it’s printing the errors in the data file being passed back.

    Hope that helps,

    Eric

    Nope that’s not it…

    define(‘WP_DEBUG’, false);

    Plugin Author ericjuden

    (@ericjuden)


    After reviewing, the client url was not set to the base site url for that client.

    Thanks Eric!

    I’m getting this as well when trying to add some clients. Not sure why, the url’s should be correct. I have a few sites on my hosting account and it only works for 1 of them. Otherwise I get:

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 3: parser error : Extra content at the end of the document in /wp-content/plugins/client-status/client-status.php on line 152
    
    Warning: simplexml_load_string() [function.simplexml-load-string]: <b>Warning</b>: session_start() [<a href='function.session-start'>function.sess in /wp-content/plugins/client-status/client-status.php on line 152
    
    Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /wp-content/plugins/client-status/client-status.php on line 152
    
    Warning: First parameter must either be an object or the name of an existing class in /wp-content/plugins/client-status/client-status.php on line 169

    I also get different errors on the dashboard page if that’s helpful:

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 3: parser error : Extra content at the end of the document in /wp-content/plugins/client-status/dashboard.php on line 79
    
    Warning: simplexml_load_string() [function.simplexml-load-string]: <b>Warning</b>: session_start() [<a href='function.session-start'>function.sess in /wp-content/plugins/client-status/dashboard.php on line 79
    
    Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /wp-content/plugins/client-status/dashboard.php on line 79

    Sorry for the 3 posts in a row but it appears that this is conflicting with other plugins, the sites I had issues with are running the wp-ecommerce and the ndizi plugin.

    I followed the instructions:

    You can check for errors in the data file by going to http://yoursite.com/wp-content/plugins/client-status/data.php?security_key=your_security_key_as_md5_hash

    and it pulled back the message from my one site of:

    <b>Warning</b>:  session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /wp-content/plugins/client-status/data.php:2) in <b>/wp-content/plugins/wp-e-commerce/wpsc-core/wpsc-constants.php</b> on line <b>17</b><br />
    ^

    and on a “test” site i run to try out different plugins it pulls:

    <b>Warning</b>:  session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /lab/wp-content/plugins/client-status/data.php:2) in <b>/lab/wp-content/plugins/ndizi-project-management/Ndizi.class.php</b> on line <b>96</b><br />
    ^

    I use wp-ecommerce on several sites. Is there a way to get this plugin to work where it’s not conflicting?

    Plugin Author ericjuden

    (@ericjuden)


    Hi Syrehn,

    Do you have WP_DEBUG enabled on your client sites? These error messages usually occur because your data file is outputting an error message at the top of the xml page. when parsing the xml it sees the error messages and interprets that as a problem in the xml file.

    Eric

    Amber

    (@syrehn)


    Hi Eric,

    Sorry this took so long for me to get back to you. I’ve been a busy bee.

    No, WP_DEBUG is not enabled on any of the client sites.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Client Status] Error log messages’ is closed to new replies.