Support » Plugin: Cleverness To-Do List » [Plugin: Cleverness To-Do List] latest upgrade blanked out the todo list

  • Just did an upgrade because the admin panel said there was a new verson.

    All the items of my todo list will not display.

    I looked in the database and they still are there for now, but I can’t guess why they don’t show up.

    How do I fix this?
    Should they have an additional setting or something?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Um – semi-solved.
    It came defaulted to categories disabled.

    I selected Enabled, and saved.
    Then I seleced Disabled, and saved.

    My stuff reappeared.

    I then re-enabled categories and tried to add a category.

    Error – “There was a problem adding the category to the database.”

    I’m wondering if there needs to be another column in the database?

    Unfortunately I don’t know this stuff well enough to implement my guesses.

    I’m going to copy out my todo data, disable the plugin, delete the database entries, and then re-enable the plugin – which I’m hoping will recreate the database stuff with all the correct settings and then re-enter my data.

    My big concern was not losing the data, which I didn’t. However, I would like to be able to take advantage of all the power in the new plugin – the category stuff etc seems very useful.

    Plugin Author Cindy Kendrick

    (@elusivelight)

    I’m not sure why there was an error adding the category, but the items not displaying may have been due to needing to click on Save Changes after enabling categories. I realize this is not ideal and have added a note to the plugin in the version I released tonight stating you need to do so.

    Category support is still fairly rudimentary at the moment. I added it because I needed it for a site I’m creating, but due to working on that site, I haven’t had as much time to devote to the plugin.

    Please let me know if you are still having problems and any specifics you are able to provide.

    cnev

    (@charlesneville)

    Eric, your suggestion worked fine. Cindy, there is a problem with legacy installs, the table doesn’t get the cat_id field added, so the INSERT query when adding a new to do item doesn’t work.

    Here’s what I did to fix the problem:
    1) Export the contents of the wp_todolist table, as a complete INSERT query (with the fields named in the query, as there’s a new field in the table for the latest version of the plugin).
    2) Deactivate then delete Cleverness To Do List plugin.
    3) Install Cleverness To Do List plugin
    4) Run the INSERT query created in step 1
    5) All looking good, insert queries work fine.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Cleverness To-Do List] latest upgrade blanked out the todo list’ is closed to new replies.