WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Clean Options] Notice: wp_specialchars is deprecated since version 2.8!

[Plugin: Clean Options] Notice: wp_specialchars is deprecated since version 2.8!

  • wpsecuritylock
    Participant

    @wpsecuritylock

    Fresh install of WordPress 3.1.3 and installed Clean Options Version 1.3.2. Activation went fine.

    But I received the following error when going to Tools > CleanOptions (cleanoptions.php):

    Notice: wp_specialchars is deprecated since version 2.8! Use esc_html() instead. in /home/test/public_html/wp-includes/functions.php on line 3303

    Notice: wp_specialchars is deprecated since version 2.8! Use esc_html() instead. in /home/test/public_html/wp-includes/functions.php on line 3303

    Notice: wp_specialchars is deprecated since version 2.8! Use esc_html() instead. in /home/test/public_html/wp-includes/functions.php on line 3303

    http://wordpress.org/extend/plugins/clean-options/

Viewing 4 replies - 1 through 4 (of 4 total)
  • wpsecuritylock
    Participant

    @wpsecuritylock

    FYI: This is with Debug True.

    Plugin Author Mittineague
    Member

    @mittineague

    Thanks for posting.

    I’ve encountered a series of distracting life events for ages now.

    I was about ready with the translations and Wham! life got in the way and kept at it.

    Things are – knock wood – finally settling down and I will hopefully be releasing the next version soon.

    And I will implement this change. Can’t let myself knowingly use deprecated code!

    @mittineague: It’s very nice to know that the plug-in will be updated. Keep up your work!

    wpsecuritylock
    Participant

    @wpsecuritylock

    Thanks for letting us know and taking care of this for us. I look forward to the updated version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Clean Options] Notice: wp_specialchars is deprecated since version 2.8!’ is closed to new replies.