Support » Plugin: CKEditor for WordPress » [Plugin: CKEditor For WordPress]   <p>&nbsp</p> Enters in the source code

  • Hello,

    There is “<p>&nbsp</p>” at the bottom of the source code.
    I set config.autoParagraph = false;

    How can I fix that issue?

    ——————————
    Example-1
    ——————————

    [How to]
    source mode -> [Before]code enter -> visual mode ->
    Click “test-test” -> source mode -> [After]code

    [Before]

    <div>
    <p>test-test</p>
    </div>

    [After]

    <div>
    <p>test-test</p>
    </div>
    <p> </p>

    ——————————
    Example-2
    ——————————

    [How to]
    source mode -> [Before]code enter -> visual mode ->
    Click “test-test” -> source mode -> [After]code

    [Before]

    <ul>
    <li><div><p>test-test</p></div></li>
    </ul>

    [After]

    <ul>
    <li><div><p>test-test</p></div></li>
    </ul>
    <p> </p>

    http://wordpress.org/extend/plugins/ckeditor-for-wordpress/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author michal

    (@michal_cksource)

    @dreki26 this is issue with CKEditor library. We can’t fix this in plugin.
    Please try use latest DEV version of our plugin which contains latest CKEditor library. Please check if it helps.

    This seems to be a major problem if we used the (in April’2013 still actually) Download-Version from WordPress PlugIn Directory – because those &nbsp;-Entitie are killed a lot of Shortcodes if there are protected spaces between the options.

    I’d got the same trouble and after an manually Update into Michal’s latest DEV version it was fixed.

    But i’m afraid i didn’t understand that in the right way?!

    Michals answer where 11 month old (today as wrote this), my normal PlugIn-Download via WP-Directory are just a couple of days ago and the diff. Timestamps into DEV-Version are just stamped between Dec 2012 into Feb 2013 – what the h… 🙂

    Maybe i’d made some mistakes by my own changes and killed them too by this Update into Michals DEV-Version?

    Anyway 😉
    Michals DEV-Link solved the effect and i recommend it, if anyone got the same trouble

    [Solved] … after Update 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: CKEditor For WordPress]   <p>&nbsp</p> Enters in the source code’ is closed to new replies.