WordPress.org

Forums

CKEditor for WordPress
[Plugin: CKEditor For WordPress]   <p>&nbsp</p> Enters in the source code (3 posts)

  1. dreki26
    Member
    Posted 3 years ago #

    Hello,

    There is "<p>&nbsp</p>" at the bottom of the source code.
    I set config.autoParagraph = false;

    How can I fix that issue?

    ------------------------------
    Example-1
    ------------------------------

    [How to]
    source mode -> [Before]code enter -> visual mode ->
    Click "test-test" -> source mode -> [After]code

    [Before]

    <div>
    <p>test-test</p>
    </div>

    [After]

    <div>
    <p>test-test</p>
    </div>
    <p> </p>

    ------------------------------
    Example-2
    ------------------------------

    [How to]
    source mode -> [Before]code enter -> visual mode ->
    Click "test-test" -> source mode -> [After]code

    [Before]

    <ul>
    <li><div><p>test-test</p></div></li>
    </ul>

    [After]

    <ul>
    <li><div><p>test-test</p></div></li>
    </ul>
    <p> </p>

    http://wordpress.org/extend/plugins/ckeditor-for-wordpress/

  2. michal
    Member
    Plugin Author

    Posted 3 years ago #

    @dreki26 this is issue with CKEditor library. We can't fix this in plugin.
    Please try use latest DEV version of our plugin which contains latest CKEditor library. Please check if it helps.

  3. freuter
    Member
    Posted 2 years ago #

    This seems to be a major problem if we used the (in April'2013 still actually) Download-Version from WordPress PlugIn Directory - because those &nbsp;-Entitie are killed a lot of Shortcodes if there are protected spaces between the options.

    I'd got the same trouble and after an manually Update into Michal's latest DEV version it was fixed.

    But i'm afraid i didn't understand that in the right way?!

    Michals answer where 11 month old (today as wrote this), my normal PlugIn-Download via WP-Directory are just a couple of days ago and the diff. Timestamps into DEV-Version are just stamped between Dec 2012 into Feb 2013 - what the h… :-)

    Maybe i'd made some mistakes by my own changes and killed them too by this Update into Michals DEV-Version?

    Anyway ;-)
    Michals DEV-Link solved the effect and i recommend it, if anyone got the same trouble

    [Solved] … after Update :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • CKEditor for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic