Ready to get started?Download WordPress


[resolved] [Plugin: CKEditor For WordPress] How to stop occasional img-wrapping? (3 posts)

  1. MathiasAeschlimann
    Posted 2 years ago #

    When I save a page or post, CKEditor occasionally wraps <img> in a <p>. On a Drupal forum, I read that

    The reason the editors wrap tags is that they're inline elements which must be contained by a block type element and are not allowed directly below the body element.

    While this statement is wrong on several points - In my case, the <img> are child to a <div>.

    Is this behavior documented? How can I prevent it?

  2. MathiasAeschlimann
    Posted 2 years ago #

    config.autoParagraph = false;

  3. michal
    Posted 2 years ago #

    Here is description of this option: link to documentation

Topic Closed

This topic has been closed to new replies.

About this Topic