Support » Plugins and Hacks » [Plugin: CKEditor For WordPress] Error on activation

[Plugin: CKEditor For WordPress] Error on activation

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author michal


    Hi, I get the error using the BuddyPress Default Theme.

    Will check against all plugins to find out more.

    I cannot provide a link because it is on a local test enironment. I made a test on a production site though and got the same error. But I cannot leave it on there because it breaks the whole site.

    There seems to be a conflict with the Advanced Custom Fields Plugin. I do not have the capabilities to understand the code so hopefully you can find out why they don’t like each other 😉

    Plugin Author michal


    @palatino thank you for that information. We try to check conflict between CKEditor for wordpress plugin and Advanced Custom Fields Plugin. Please be patient.

    @michal_cksource Promised! Thank you for your alertness.

    Meanwhile I found something else. Again I do not know what the initial reason is but using CKEditor for WordPress and the W3 Total Cache Plugin turns out to make the editor field invisible in the comments area.

    After testing a while I found that this is due to the minification of javascript by W3TC. SO at this point I disabled js minification but that is not the solution for long term, is it? I would appreciate if you look into this and check if it is a bug in script enqueuing or something else.

    Plugin Contributor dczepierga


    @palatino: I fix problem with Advanced Custom Fields Plugin and commit it to SVN at revision: 504269.

    Here you can download latest DEV version of plugin:
    DEV version link. Please try this, but remember that this is beta version of plugin.

    Plugin Contributor dczepierga


    @palatino, i check CKEditor plugin with W3 Total Cache and for me everything works fine. Pls check this with last DEV version of CKEditro plugin and last stable version of W3 Total Cache plugin.

    If it doesn’t help, pls write all your enabled settings of W3 Total Cache plugin.
    Akso try to check other browsers, may be only on this one which u use is problem with it – if yes pls write which browser do u use (with version of browser)


    I have the same problem as palatino and could not find it in the forum after looking for hours and therefore posted my own bug report.

    I tried so many things, I used CKEditor versions and, deactivated all plugins, and activated one by one and found the problem to be with W3 Total Cache. I get no comment editor, it’s invisible like palatino described it.

    Thanks to palatino I know at least that if I disable js minification it solves it for now but caching and page loading speed is really important, so I will be eagerly awaiting the fix or consider some of the other WYSIWYG editors.

    Plugin Author michal


    @palatino and @hotmailpbpb,
    do you see any errors in Firebug (Firefox add-on) console ?
    Please also check Firebug’s NET tab if all request are correct.
    What settings do you have for W3 Total Cache plugin ?
    What js minification method do you use ?
    Did you cleared cache after CKEditor plugin update ?

    I am not familiar with Firebug, but this is what I did:
    (1) went to Firebug/Inspect Element
    (2) I don’t see the word “Error” anywhere so don’t know if there are errors
    (3) I clicked on the NET tab, activated it and it’s blank
    (4) In W3 Total Cache plugin, if I uncheck the “enable” box “JS minify settings:” then CKEditor works fine. If I check the box, and no other box, the problem reappears.
    (5) I clear the cache all the time as I update/enable/disable plugins or install new ones – I also clear it before and after a change to JS minify.

    What now?

    Plugin Author michal


    errors in Firebug should be in console tab. There are red messages if something goes wrong. In Net tab you will see results only when you activate this tab and refresh page.
    Can you write (make screenshot) , what are your ‘minify’ settings for W3 Total Cache plugin ?
    What server, php version and operating system do you use ?
    We need more information, because we can’t reproduce this issue.

    Okay, here are some screenshots.

    I am using WordPress 3.3.1.
    and this:
    Apache version 2.2.21
    PHP version 5.2.17
    MySQL version 5.1.56-log
    Architecture x86_64
    Operating system linux

    Anything else you need let me know and I’ll get it. I want my pages to load faster – which is what minify does.


    Plugin Author michal


    @hotmailpbpb thank you.
    I found way to reproduce this issue.
    We try fix this as soon as possible. Please be patient.

    Carl Rozema


    @dczepierga I also got the deprecated.php line 728 error, after installing ACF. Is the 504629 fix already in the latest version or still in DEV?

    I try not to update CKeditor too often, because I loose my templates on each update. I know I have to copy the template.js file before I do the upgrade, but it makes updating al little less easy…


    Plugin Author michal


    Hi guys,
    I added small fix to this. You can check this with latest DEV version from: http://downloads.wordpress.org/plugin/ckeditor-for-wordpress.zip
    This turn off minify js files on page where CKEditor is used to comment form. This is not ideal solution.
    Please check it but, remember this is a DEV version of plugin.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: CKEditor For WordPress] Error on activation’ is closed to new replies.