Support » Plugins » [Plugin: CKEditor For WordPress] Ckeditor isn't show by default when page loads

  • Hi
    I’ve installed CKeditor and it’s working great,but When I start a new post I can’t see the editor and there is only a withe box with 2 tabs (Visual and html) and I have to click on “Visual editor” once and then CKEditor appears.
    I can work with this problem but other authors thinks there is no editor when the are open new_post page.

    * Editor shown in post excerpt section each time and this problem is only in main editor (Top of Post Excerpt editor)
    Thanks, Sorry for English mistakes.

Viewing 15 replies - 1 through 15 (of 15 total)
  • michal


    please check “Default state” option in “Basic settings’ tab in CKEditor plugin configuration. Is it checked as enabled ?

    Yes it’s enabled. If I disable it both Visual and Html tabs will not work anymore, and when it’s enabled the problem that I told will occurs,



    Please check if you see any errors in Firebug or similar tool.
    Do you have this problem with all browsers ?
    Please also check if this problem exists in DEV version
    What template/theme do you use ?

    Problem exist in all browsers (Chrome, Firefox). in IE it didn’t show at all and both tabs are disappeared.
    Same problem with DEV version (Installed from your link)
    Is theme important? because administration area uses default theme.
    in CKEditor I’d also tried different skins. no difference.
    would you like to give you a test author account?



    yes please give me access to your site.

    My site language is in Persian but you can work with it:
    User: michal
    password: michal
    DEV version is installed withoud CKFinder.
    Link to new post:

    My active plugins:

    All-in-One Calendar by
    All in One SEO Pack
    Auto Post Thumbnail
    Broken Link Checker
    Category Posts Widget
    CKEditor for WordPress
    Cleaner Gallery
    Contact Form 7
    Display widgets
    Disqus Comment System
    External DB authentication (MyBB Remix)
    File Gallery
    Google Analytics for WordPress
    Google XML Sitemaps
    jQuery Lightbox For Native Galleries
    Login Logout
    MyBB Latest Posts
    Page Excerpt
    RSS Importer
    RSS Poster Free Version
    Share Buttons by Lockerz / AddToAny
    Sidebar Login
    TGN Embed everything
    TinyMCE Excerpt
    Use Google Libraries
    WordBB – WP side
    WordPress Google +1 Button – Advanced Plugin, Includes Redirection
    WordPress Related Posts
    WP Super Cache



    There is an error tinymce.EditorManager.get is not a function in File Gallery plugin (please check Firebug). Please try check if disabling this plugin fix your issue.
    For the future , please don’t give access to your site in public place like this. Remove mentioned user account ASAP.

    Thank you so much. Sure. I will remove that account.
    But I’d removed tinymce and I’m using CKeditor. :-\
    That’s great. Thank you so much Michal.
    I was disabled tinymce editor but the problem was “TinyMCE Excerpt” plugin.

    Thank you so much. 🙂

    Is it possible to have CKeditor in excerpt? That “tinymce excerpt plugin” plugin was do this for tinymce editor.



    I committed small fix to revision: 544068.
    This fix is related with File Gallery plugin compatibility.
    Please check latest DEV version.

    Support for excerpt plugin is added to our new feature tickets list :



    I committed support to excerpt field in revision: 545270

    Thanks Michal 🙂


    I am having the same problem when I am using CKEditor with bbPress.

    I don’t know where I should be looking to fix this. Can you please help?

    The website is



    All fixed.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: CKEditor For WordPress] Ckeditor isn't show by default when page loads’ is closed to new replies.