CKEditor for WordPress
[resolved] [Plugin: CKEditor For WordPress] Buttons not appearing (8 posts)

  1. Naoise Golden Santos
    Posted 5 years ago #

    Some buttons provided by other plugins, like for example RB Internal Links plugin's button, don't appear in the CKEditor toolbox.

    I keep activating and deactivating CKEditor plugin to be able to use all the options!


  2. dczepierga
    Plugin Contributor

    Posted 5 years ago #

    This buttons are not supported by CKEditor, because plugin RB Internal Links support only original WYSIWYG editor from WordPress.
    So we can't do anything to show something which is not supported by CKEditor. If they add support in their plugin for CKEditor, we also add buttons in defaults toolbars for their plugin and then everything will be work.

  3. luis.sg
    Posted 4 years ago #

    Hello! U don't have any other additional buttons or plug-ins, and yet my CKEditor doesn't show up. Looks like there are some 404 errors, as if the editor was trying to fetch the files from somewhere else.

    It's been two days with the error. Now I've found the 1.0.4 version and I've installed it, hoping that it would fix the problem. But... nope. Still failing. It's like CKEditor doesn't work at all anymore. I've tried activating it, deactivating, installing, uninstalling...

    My wordpress version is 3.0.3. Browsers are FIrefox (latest) and Chrome (latest). It worked a few days ago.


  4. pkemke
    Posted 4 years ago #


    I would love to use your plugin. However I am having similar issues to those listed above. When I install and activate your plugin it does not work.

    I can see the editor when adding a new PAGE only.

    I can not see the editor when editing a pre-existing page.

    I can not see the editor when adding a new post.

    I can not see the editor when editing a pre-existing post.

    Other than opening multiple tabs and copying and pasting code between tabs I don't see how this will work for me. I have tested the plugin in IE 7 and Google Chrome (latest version as of 1/26/2011) and I get the same results as noted above. Also I updated my version of WordPress to 3.04.

    Any suggestions would be greatly appreciated as I would like the ability to use full featured word processor type editor.



  5. wiktor
    Plugin Author

    Posted 4 years ago #

    @luis.sg, @pkemke - I know you have posted your comments long time ago and noone answered you, but is there a chance that you could get back to this issue and let us know if it still does not work for you?

    Do you see any JavaScript errors on the page where CKEditor does not show up? Could you check it in Firebug if CKEditor does not show up in Firefox? In case of other browsers please also check the error console for any possible JavaScript errors.

    Are you using a non-default template? Can it be downloaded somewhere?
    Do you have any other plugins installed in WordPress? Could you list them?

    Could you check the Net Panel in Firebug (or use any other tool to track HTTP requests, like Fiddler)? Are all files loaded correctly? Do you see there any HTTP errors (like 404)?

  6. luis.sg
    Posted 4 years ago #

    Hi @wiktor,

    I found the error, but not a proper solution, just a workaround. As you've suggested, there were 404 errors; some JS files weren't loading. It wasn't consistent: when I disabled/re-enabled CKEditor, it worked like a charm the first time. But the moment I updated/published my entry, the the editor appeared broken and remained so unless I disabled/re-enabled it. Since it wasn't a good solution, I eventually tracked all the missing files. I realized CKEditor was trying to load assets from the wp-admin directory. My first thought was that some setting, probably a basePath var was not being initialized. So I started debugging and trying many things. I tried setting it up myself after document.ready, but some other files were overriding the value. I finally decided to use another editor, but I did a last dirty trick, which was copying all the files the editor was trying to load from wp-admin to that folder. It worked but still it was a nasty workaround, and I finally switched to another editor and lived happily ever after.

    I am using the "motion" template, which I found at wordpress.org, so I supposed it is standard. And anyway, I don't think my template has anything to do with the back-end application, those are different scopes and whatever scripts my template loads and uses, they're not present when I get to the back-end.

    I must say, though, that all those errors are gone with current versions of WordPress (3.1) and CKEditor. Still, I think there was a lack of support given the number of affected people and the popularity of CKEditor. Yes, it's free, but when it messes up with so many people's blogs, I think the least they can do is to say "we know it's been broken for two months, we're working on it".

    Anyway, that's just philosophy :-) I hope you find my answer helpful. Happy blogging!

  7. wiktor
    Plugin Author

    Posted 4 years ago #

    Hi luis.sg,

    Thank you for a prompt reply. I definitely agree it was not the smartest thing to leave your comments unanswered for so long.
    I hope it will not happen again.

    We will try to tack down the problem as it looks that some users are still experiencing it. Knowing the whole scenario where CKEditor didn't work for you may definitely help us, at least in discovering what was wrong earlier, thank you!

  8. luis.sg
    Posted 4 years ago #

    @wiktor, in case it helps, read this:

    I posted all the problems & different workarounds I figured out, as well as a detailed list of the errors.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • CKEditor for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic