WordPress.org

Support

Support » Plugins and Hacks » CKEditor for WordPress » [Plugin: CKEditor For WordPress] Blank white edit screen

[Plugin: CKEditor For WordPress] Blank white edit screen

Viewing 15 replies - 1 through 15 (of 35 total)
  • Plugin Author michal

    @michal_cksource

    Hi,
    please try use latest DEV version from link. Please write us if it helps or not.

    Thanks for your quick reply – unfortunately I’m still getting the same issue.

    Cheers,
    -FJ

    Plugin Author michal

    @michal_cksource

    Thank you for checking latest DEV.
    Please check in Firebug (Firefox add-on) console if you have any errors .
    Please also check in firebug’s net tab if all request are correct.

    I had the same issue, afer debugging with firebug and crossing it with Apache logs, I found out that the plaugin was requesting the JS files using the HTTPS protocol prefix. After a short investiagtion, I found that in file ckeditor_class.php in line 30 there was:

    if($_SERVER['HTTPS']) {
      $siteurl = str_replace('http:', 'https:', $siteurl);
      $this->plugin_path = str_replace('http:', 'https:', $this->plugin_path);
    }

    Apparentaly my server configuaration was producong

    $_SERVER['HTTPS']='off'

    The following fix should be applied to the plugin code, using a core wordpress function to check the required protocol:

    if(is_ssl()) {
      $siteurl = str_replace('http:', 'https:', $siteurl);
      $this->plugin_path = str_replace('http:', 'https:', $this->plugin_path);
    }

    Plugin Author michal

    @michal_cksource

    @alex Sherman thank you for your search and suggestion how to fix this issue. We try fix this as soon as possible. Please be patient.

    Plugin Contributor dczepierga

    @dczepierga

    @alex Sherman thx for your help, i commit changes to SVN.

    Greetings

    In my opinion this plugin won’t load on every webserver running IIS with PHP using ISAPI. The value of $_SERVER[‘HTTPS’] would be ‘off’ and in this case not empty as expected…

    When will be the next plugin update?

    Thanks for the great work!

    Actually I had this on Apache on Ubuntu system (installed as Zend Server Ce PHP 5.3)

    Plugin Author michal

    @michal_cksource

    @bannerweb GmbH,
    this bug is fixed in latest DEV version. Please try use it.
    Dev version has also CKEditor 3.6.3 (latest one).

    I’m still having some issues with the a blank editor after enabling CKEditor…

    The only error I’m seeing when I attempt to make an edit, is as follows.

    Also I am on the latest DEV version.

    Headers:

    GET ckeditor.js?ver=3.3.2

    500 Internal Server Error

    www2.autani.local

    617 B

    172.21.18.66:80

    4ms
    ParamsHeadersResponseCache
    Response Headersview source
    Connection close
    Content-Length 617
    Content-Type text/html; charset=iso-8859-1
    Date Fri, 18 May 2012 18:48:14 GMT
    Server Apache/2.2.15 (CentOS)
    Request Headersview source
    Accept */*
    Accept-Encoding gzip, deflate
    Accept-Language en-us,en;q=0.5
    Connection keep-alive
    Cookie wordpress_aa2d82e81d80d2af647335df946511f3=admin%7C1338574660%7C31745ca464a06a0eb1f66968d7454827; wordpress_logged_in_aa2d82e81d80d2af647335df946511f3=admin%7C1338574660%7C332c60f492fe4830edec0ddd5f34d08a; wp-settings-time-1=1337366894; wordpress_test_cookie=WP+Cookie+check
    Host www2.autani.local
    Referer http://www2.autani.local/wp-admin/post.php?post=1&action=edit
    User-Agent Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0

    Response:

    <!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
    <html><head>
    <title>500 Internal Server Error</title>
    </head><body>
    <h1>Internal Server Error</h1>
    <p>The server encountered an internal error or
    misconfiguration and was unable to complete
    your request.</p>
    <p>Please contact the server administrator,
    root@localhost and inform them of the time the error occurred,
    and anything you might have done that may have
    caused the error.</p>
    <p>More information about this error may be available
    in the server error log.</p>
    <hr>
    <address>Apache/2.2.15 (CentOS) Server at www2.autani.local Port 80</address>
    </body></html>

    Issue solved! I had to disable the .htaccess file by renaming it .htaccess.bk everything is working now 🙂 Any negatives to disabling that file??

    Plugin Author michal

    @michal_cksource

    @dmillerzx,
    you mean .htaccess file in CKEditor plugin directory ?
    This kind of issues are related with server configuration.
    If everything works fine after your change, it should be ok.

    Yes I completely disabled the .htaccess file under plugins/ckeditor-for-wordpress/ckeditor After doing this CKEditor loads as it should, no more white/blank editor! 🙂 🙂

    I’m not sure where I would have configured the server wrong, started up a fresh VM for this guy. Fresh CentOS 6.2, with latest Apache, mySQL, and dependencies.

    Thanks for the feedback.

    Hello.

    I had the same problem (blank white editor screen).

    Because the plugin was working up to some point I later discovered that the “Google XML Sitemaps v3 for qTranslate” (3.2.7.1) plugin was causing this plugin to stop working.

    Hopefully this will help someone…

    Plugin Author michal

    @michal_cksource

    @smile-,
    can you write us if you have any errors in Firebug or similar tool when you try to use CKEditor for WordPress and “Google XML Sitemaps v3 for qTranslate” plugins

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘[Plugin: CKEditor For WordPress] Blank white edit screen’ is closed to new replies.
Skip to toolbar