WordPress.org

Support

Support » Plugins and Hacks » Cimy User Manager » [Plugin: Cimy User Manager] not exporting all members

[Plugin: Cimy User Manager] not exporting all members

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Author Marco Cimmino

    @cimmo

    Plese read the FAQ and provide missing info.
    Also enable debug and paste the error:
    http://codex.wordpress.org/Editing_wp-config.php#Debug

    Ok, I’ve read the FAQ and changed some lines in php.ini but still no luck.
    In fact the output file each time has a different size.

    Enabling debug I got:
    Notice: Undefined offset: 0 in /home/content/98/7035098/html/XXXXXXX/wp-content/plugins/cimy-user-manager/cimy_user_manager.php on line 975

    Can you help me?

    Plugin Author Marco Cimmino

    @cimmo

    If you read the FAQ where are the missing info requested? Version of the plug-in used?? Come on.

    You need help, I need information.

    VersiĆ³n 1.2.0

    Changed:
    max_execution_time = 0
    max_input_time = 1024 (tested some other values but no luck)
    file_uploads = On
    upload_max_filesize = 40M
    post_max_size = 40M

    Plugin Author Marco Cimmino

    @cimmo

    I can see the problem only on line 974, but not 975 can you check again?

    Notice: Undefined offset: 0 in /home/content/98/7035098/html/anper/wp-content/plugins/cimy-user-manager/cimy_user_manager.php on line 975

    $field_separator.$text_separator.$current_user->roles[0].$text_separator. is my line 975

    Plugin Author Marco Cimmino

    @cimmo

    That line is 974 for me on v1.2.0 – did you modify the plug-in? I suggest to wipe out that version and reinstall.

    It is weird anyway that you have that error, that means you have an user without roles?

    Wiped and still the same. Now the error is at line 974:
    Notice: Undefined offset: 0 in /home/content/98/7035098/html/anper/wp-content/plugins/cimy-user-manager/cimy_user_manager.php on line 974

    But when this notice appears the process is still running, I mean, this notice does not break the process.
    After a few seconds I got a blank screen.

    I have no users without roles, and if fact sometimes the export process stops at 2422 users and sometimes at 2467, but never at the total (3.815).

    Plugin Author Marco Cimmino

    @cimmo

    yea 974 makes sense, well kinda, still no idea why it happens. But I’ll see if I can fix it.

    Could it be a “memory” problem or similar? Because the exported amount is variable.

    Plugin Author Marco Cimmino

    @cimmo

    It might be, but you tried all the faq but not the one that really matters about memory usage.

    You need to change the memory limit:
    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Changed to 96M, same results.
    The exported (but truncated) file is about 1,1MB.

    Maybe can help but when importing amounts near to 100 users I got a blank screen, sometimes all are imported sometimes I have to split the csv in 2 parts.
    But if I have luck all 100 users are imported with the successfully screen.

    Or maybe taking a look to my DB you could find the limitation…

    Plugin Author Marco Cimmino

    @cimmo

    But the problem is _importing_ or _exporting_? You are making such a confusion here.

    Both.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘[Plugin: Cimy User Manager] not exporting all members’ is closed to new replies.
Skip to toolbar