• Resolved Rami

    (@rami4625)


    After i started using the plugin the authors links like :
    elakademiapost.com/author/author-name/
    changed to :
    elakademiapost.com/profile/author-name/

    But i don’t want this to happen,
    So how can i prevent that?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,

    You can enable the setting at UsersWP->General->Profile->Show Advanced->Disable author redirect to UsersWP profile page. and let me know if it works for you or not.

    Regards,
    Patrik

    Thread Starter Rami

    (@rami4625)

    That worked, Thank you for helping,

    But i have a similar problem with register & forgot password pages,

    when user click on register or forgot password buttons in login page :
    elakademiapost.com/wp-login.php
    then he redirected to the plugin pages,
    I tried to deactivate Redirect Admin Default Register Page option but nothing changed.

    Hi,

    That’s because we use WP filters ‘register_url’ and ‘lostpassword_url’ to modify the URL everywhere and so is on the admin page as well.

    Regards,
    Patrik

    Thread Starter Rami

    (@rami4625)

    @wpdev10 how can i prevent that?

    • This reply was modified 8 months, 2 weeks ago by Rami.

    Hi,

    You can override it by using the same filter with your own code but it might break our functionality as the same filter is used on the frontend as well. You can see how we use it here: https://github.com/AyeCode/userswp/blob/61790d4c2ce73145def6b8c12ba121699feaaccf/includes/class-userswp.php#L723

    Regards,
    Patrik

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin change authors links’ is closed to new replies.