Support » Plugins » [Plugin: cformsII – contact form] Incompatibility with WP 2.7 admin theme

  • Resolved eharris


    I’ve noticed that when I’m on any of the cforms configuration pages, the AJAX features of the new WordPress 2.7 admin interface fail. I cannot expand or contract any of the menu categories. I cannot shrink or grow the menu panel, and most importantly, if I’m using the small icon-only menu, the menu options don’t appear upon hover, and the icon itself is not clickable, leaving me stuck on the cforms config page. Version 9 is listed as being compatible with WP 2.7, but apparently it’s not totally compatible yet.

Viewing 15 replies - 1 through 15 (of 15 total)
  • cforms v9.3 is indeed compatible with plain vanilla WP 2.7 it may however not be compatible with your setup (e.g. other admin plugins/settings you’re using)

    I put together a very basic test site in preparation for 2.7 (to make sure my themes and plugins would survive the transition), and I just confirmed the bug described above with all plugins inactive except cforms v9.3, and even with the WordPress Default theme active (though that doesn’t matter, since the issue is with the AJAX features in the back-end menu, which aren’t themed).

    The plugin is compatible with WordPress 2.7 in the sense that all of the options work, and nothing is broken for the website end user, but on all four installations of WordPress I’ve tested it on (three live and one test), the AJAX features of the admin menu (expanding/contracting menus, popup menus for icon-only menubar) don’t work from any of the cforms config pages.

    I’m using Firefox 3.0.4 in Windows (XP, 32-bit), in case this bug happens to be browser-dependent.

    cforms II works fine in my WP 2.7. In the admin dash’ and throughout. I am using about 40 plugins…just made the upgrade to 2.7 mmmm…yesterday?…or the day before. lol I had MANY problems to overcome and have overcame them all thus far.

    I suggest deactivating cforms. Deleting the plugin folder. Uploading cforms again only this time via FTP. Then activate cforms. This worked for me on a couple of plugins…one of which was TinyMCE Advanced, with that particular plugin…errors were in the admin dash. Not anymore.
    Hope this helps…
    David M. Sellers

    No such luck. I deleted it and uploaded it via FTP from scratch. I also used cforms’ own uninstall routine and deleted ALL cforms data and started over from scratch. It seems unlikely that an intermittent bug like the ones you describe would manifest itself on four separate installations (one of which is not a 2.6->2.7 upgrade).

    Very specifically, this is how I’m seeing this bug.

    1 – Go to the WP Admin screen.
    2 – Click on the cformsII item on the left. It should auto-expand.
    3 – Hover over the “Posts” menu and click on the down arrow on the right side of the menu bar. If it’s expanded, it won’t shrink back down. If it’s shrunken, it won’t expand.

    You can repeat step 3 for any of menus. None of them will expand/contract to show/hide their submenus. You can also repeat step 3 by clicking on the double-left arrow right underneath the Dashboard item. It’s supposed to iconify the menu. It doesn’t if I’m in any of the cformsII menus. Other plugins that add their own top-level menu item (e.g. Lester Chan’s email, database, and ratings plugins) don’t exhibit this behavior, so it’s not a problem inherent with WordPress 2.7 itself. This is more of a problem when the menus are already iconified (no text), because then they don’t work at all from any of the cforms config screens.

    All other aspects of cforms seem to work fine. The AJAX features in the cforms config screens themselves work. It’s only the WP admin menu AJAX features that show a problem. And this problem exists whether cforms was upgraded automatically or via FTP, whether WordPress was upgraded from 2.6 to 2.7 or a straight 2.7 install, and whether or not I tell cforms to delete all of its config data from the database.

    I’ve confirmed that the bug exists in IE7 as well, so it’s not browser-dependent.

    Don’t know what to say about that. Good luck. I will ponder it a bit…as I am working on plugins at this moment…pods, simple forums and wordtube.
    I only know very little code…enough to understand (mostly) how most programming functions etc…I have only been using WP for about four weeks. The majority of my issues I had to resolve myself…couldn’t seem to get straight answers. As you seem to be getting from ME now…no answer at all. Please forgive.

    Most of my errors where with conflicting plugins or having to use FTP instead of auto. Keep trying…If I find “anything”, eharris, I will let you know. Best that “I” can do. And your problem seems to be WP (AJAX) itself…odd.
    Just thought of something…
    Do you have “ANY” plugins that modify the admin panel dashboard at all? I had NO left side dash AT ALL when I installed WP 2.7(upgraded) I deactivated…admin extend’, lighter menus…and one more(?)…That fixed my problem then. Take a look see…


    eharris, I’ll take a closer look at the final 2.7 release. There indeed seems an issue with conflicting jQuery instances (>> when using “iconified” admin UI )…funny that this wasn’t an issue with the beta 2.7 version…oh well, wonder what will break next in WP 2.8…

    Raginwolf – no, I’m not using any plugins that modify the admin menus. Plus, as I said, I disabled all plugins except for cforms on my test site to verify that the bug still showed up.

    I was using Ozh Admin Drop Down Menus with 2.6, but since its main functionality is built into 2.7, I’m not using the 2.7 version (which puts the menus back on top). Since my test site started with 2.7 Beta, I never had that plugin installed on that one, though, so this problem can’t be caused by any “database residue” from that.

    I do appreciate the help you’re trying to offer, and Oliver, I appreciate you looking into it. Oliver, if it’ll help, I should be able to set up a temp admin account for you on my test site, and I might even be able to set up an FTP account that can only access that directory on my hosting account. Since the site exists solely to test changes I want to make to my other sites. If you think that’ll help, send me a private note via

    Incidentally, I finally updated my remaining WP site to 2.7, and it exhibits the same problem. This fifth site is on a different web host (1&1, vs HostGator), and is one I run for a local community organization. So that seems to rule out a host-specific problem, since these are two different hosts, running two different versions of various server-side tools (different versions of PHP, SQL, with HostGator almost universally running more up-to-date software).

    thanks for the offer eharris! on my latest wp 2.7 install I can already see the issue with Javascript.

    essentially cforms is breaking the JS popup/dropdown feature of WP2.7 – which is also based on jQuery.

    I’ll fix this as soon as I can – luckily it’s only an annoying bug (when accessing the cforms tabs) and not one that breaks WP altogether.

    Why is it working perfectly on my set-up? My cformsII has been part of my set-up since 2.6.3. I find that to be odd and even interesting.
    Hope you get that fixed guys.

    I’m also using cforms 9.3 with WP 2.7 and have found a possible incompatibility. When I click on “Update Settings” to save changes to a form, I receive a 406 error “An appropriate representation of the requested resource /prod/wordpress/wp-admin/admin.php could not be found on this server.”

    This is my first cforms install, so it is also possible that I have messed something up.

    *Edit to fix WP version number typo.

    Where is my plug in area now? Is there a post somewhere that shows us how to use this new interface. I did not realize I would have to relearn where everything is located now. Not feeling happy about this right now.

    I too have 2.7 installed with 9.3 cforms. My problem may be a different one. My system has over 10 forms installed. When I get into the form management screen I see a blank form at the 10th form.

    I then deactivated and reactivated but still had a few lost forms.

    I did a save all settings and examined the output. What I found in the output were a few forms both named cforms1 and no cforms10 or cforms11. The form selection drop down now has two blank forms in the middle.

    Any ideas?

    Thanks for the quick fix, Oliver. Version 9.4 resolves this minor issue.

    Still using 9.3. No problems…

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: cformsII – contact form] Incompatibility with WP 2.7 admin theme’ is closed to new replies.