WordPress.org

Forums

[Plugin: cForms II] Secure Forms (7 posts)

  1. databell96
    Member
    Posted 6 years ago #

    I'm trying to figure out if there's a way to make a cForm secure or if there's another plugin out there to allow for a full customizable form that's secure. My clients wants to do a https secure form for his site and I prefer doing it within the WP environment instead of creating one in Dreamweaver.

  2. Michael Torbert
    WordPress Virtuoso
    Posted 6 years ago #

    Sure, CFormsII lets you change the form action to whatever you want. So just change the form action to https://... I'm assuming you already have SSL set up for whatever domain it will be submitted to.

  3. databell96
    Member
    Posted 6 years ago #

    Honestly, I don't know. Client is responsible for that but I can find out. He's hosted on Powweb.

  4. databell96
    Member
    Posted 6 years ago #

    OK, there is. It would be https://username.powweb.com/ where 'username' would represent the username of the owner of the site. Not the domain name but the username. So how would I properly change the form action in cForms?

  5. Michael Torbert
    WordPress Virtuoso
    Posted 6 years ago #

    Take a look at the documentation/forums for the plugin on delicious days. There are threads discussing CForms' support for https.

  6. databell96
    Member
    Posted 6 years ago #

    I did but quite frankly, their forums really suck. I can't find anything there.

  7. damania
    Member
    Posted 5 years ago #

    I figured it out.

    First, I went into wordpress general settings and changed the wordpress and blog address to https://(site). Then I went to cforms and went to the exact form and updated it (update button on top right side). Then I went back to general settings and rechanged it back to http://.

    Then I changed the cforms_root line as referenced here in entry 4:
    http://www.deliciousdays.com/cforms-forum/troubleshooting/https-problems/

    Then the captcha and submit button wouldn't work, so I went into plugin editor -> cforms -> js/cforms.js and changed the sajax_uri variable to either 'https://(fullpath)' or '/wordpress/wp-content/plugins/cforms/lib_ajax.php';

    The path may or may not include /wordpress for you depending on your path.

    My website is at http://3packet.com

    Good luck all!

Topic Closed

This topic has been closed to new replies.

About this Topic