WordPress.org

Support

Support » Plugins and Hacks » CDN Sync Tool » [Plugin: CDN Sync Tool] CDN Sync Breaks after upgrade

[Plugin: CDN Sync Tool] CDN Sync Breaks after upgrade

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Ollie Armstrong

    @olliea95

    I apologise for all inconvenience that this premature update has caused. I assure you that I am looking at this issue now.

    If there are any further issues or any more information that may help me to fix this issue then please feel free to provide it on this thread or another thread.

    Well, I have upgraded and it is still broken? The biggest question is do we need to remove the plugin and reinstall it? And if so, when we try to sync will it know what is already there and not try to resync or cause us to have to resync our entire content? It is still doing the same thing it was right after the 2.0 upgrade, just says All Files Synced.

    Broken for me too.

    Media files don’t upload, plugin simply says everything is synced, even if I check the override option.

    It also wiped all the settings when I upgraded.

    And i now have a duplice folder on my S3 account in the uploads folder.

    So after many attempts to get this working I finally decided to remove the plugin and try to reinstall. Initially this did not work so I checked the tables in my db and saw that the cst_files table was still there. I decided to wipe it out just to see what would happen.

    Removed the table and did a reinstall of the plugin…everything worked. The best part was that it didn’t have to resync everything and only did the changes.

    Your mileage may vary but this at least worked for me.

    My fix was simply downgrading to the older revision. That works fine. One should be careful upgrading this, especially if the older version works. Maybe vSential’s fix works for the new version, but this should not need to be done during the upgrade process.

    Plugin Author Ollie Armstrong

    @olliea95

    An update is about to be pushed that should correct this issue. There is indeed database problems that I have attempted to fix. Please let me know how it goes after updating to the upcoming 2.0.3.

    Regards,
    Ollie Armstrong

    Can anyone get this to work now? When I attempt to sync, it says ally my files are synced, yet I see nothing on Amazon s3. I’m new to this, any help would be appreciated. Please help me.

    Simply doesn’t do what it used to. I got it to sync some image files on my WP multisite child blog, but none of the theme files or JS or CSS files.

    Breaks for me too. Also, it forgot my S3 key.

    It’s a great plugin. Good luck fixing it soon.

    It might relate to the end of file names, e.g., ‘-240×61.png’.

    Plugin Author Ollie Armstrong

    @olliea95

    I have uncovered a major issue, the plugin wouldn’t recursively check directories, hence why there were no files found in wp-includes.

    This has now been fixed and I have just pushed an update 2.1 to include this fix. On a fresh install of WordPress there are now 300+ files to sync immediately. Much more like how it used to be on pre 2.0 versions.

    I hope most issues are now solved.

    Re: idea.org;
    Please let me know if this update fixes your issues.

    Looks better, uploaded all my js, plugin and theme files.

    Downside is, it also uploaded all the image uploads for all my multisites to to a blog.dirs folder.

    Is there any way of only uploading files used on the current multisite. I’m using seperate buckets for each multisite site.

    thanks for all the hard work

    Plugin Author Ollie Armstrong

    @olliea95

    I haven’t initially made it multisite compatible so these enhancements will have to come as a future update. I will be working on it as soon as I can.

    Regards,
    Ollie Armstrong

    Actually, it’s not working on my site. It uploaded all files as stated, but when I enabled CDN support in WP Super Cache, cleared the cache and refreshed pages, none of the style sheets are being loaded so the site is displaying really badly.

    Multisite not as big an issue, it just means duplicates of files on the cloud, I can live with that. Only they are not being loaded from themes.

    Any ideas?

    Thanks again.

    I am having the same issue as Pete_PT. Not the multisite portion but the style sheets don’t seem to be loading at all. They are on the CDN as I have verified they are there but for some reason they do not load.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Plugin: CDN Sync Tool] CDN Sync Breaks after upgrade’ is closed to new replies.
Skip to toolbar