Support » Plugin: NavMenu Addon For Elementor » Plugin causes JavaScript error and breaks others

  • Resolved Ramona (from Nextend)

    (@nextend_ramona)


    Hi,

    Your plugin causes a JavaScript error and breaks several other plugins, including Smart Slider 3. Please fix it.

    The error is:
    TypeError: this.el is null
    pointing to /wp-content/plugins/navmenu-addon-for-elementor/assets/js/frontend.min.js

    Theme: Twenty Fifteen (2.0)
    WordPress 4.9.8
    Active plugins:
    Elementor 2.2.2
    NavMenu Addon For Elementor 1.1.2

    Installing the suggested Elementor Addons & Widgets (1.2.5) plugin does not fix the problem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Confirm, the same bag.

    _init : function() {
    	var el;
    	this.current          = -1;
    	this.touch            = Modernizr.touch;
    	this.menu             = this.el.querySelector( '.cbp-hsmenu' );
    	this.menuItems        = this.el.querySelectorAll( '.cbp-hsmenu > li' );
    	this.menuBg           = document.createElement( 'div' );
    	this.menuBg.className = 'cbp-hsmenubg';
    	this.el.appendChild( this.menuBg );
    	this._initEvents();
    },

    The mistake is obvious, property el is undefined.

    @themeisle, fix please!

    Plugin Support Poonam Namdev

    (@poonam9)

    Hello @hokku & @nextendweb,

    I’ve reported this bug to our developers and will be resolved as soon as possible.

    Sorry for the inconvenience.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.