WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Category Template Hierarchy] Works in mu-plugins?

[Resolved] [Plugin: Category Template Hierarchy] Works in mu-plugins?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Eddie Moya

    @eddiemoya

    I can’t honestly think of any reason it would not work in mu-plugins, but to be honest I have not worked with that folder since before 3.0, when WPMU was separate from WP, so I can’t recall what complications it had.

    Give it a try, and let me know how that goes. If there is a problem with it working in mu-plugins, I’d love to know because at work (where this plugin was developed), they’ve expressed using multisite for the first time at this company (Sears), for a large upcoming project.

    Let me know if you do or dont get it to work, I’d love to know, and If it doesn’t work I’ll do my best to fix whatever is wrong with it in a timely manner.

    Thanks

    If I try it, I’ll give it a shot. It will almost certainly take a bit of tweaking. Check out the caveats section of the Codex page. FYI, although it started for multi-user sites, the mu-plugins folder stands for “must-use” and can be used on single-site installs.

    Thanks for the responses.

    Plugin Author Eddie Moya

    @eddiemoya

    A look at that codex page would indicate to me that there should be no problem using this plugin in mu-plugins, with the exception of it needing to be loaded from a proxy file thats not in a subdirectory.

    I don’t know how you do it, but if it were me I’d write an autoloader for that rather than including them one by one. In any case, I dont think it should be a problem at all as far as I can tell.

    Let me know how it goes.

    Plugin Author Eddie Moya

    @eddiemoya

    Marking this as resolved, since I assume if there were still problems I probably would have received a follow up question here.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: Category Template Hierarchy] Works in mu-plugins?’ is closed to new replies.