Support » Plugin: CataBlog » [Plugin: CataBlog] SyntaxError after setting color

  • I installed Catablog 1.5 and went to the Options to set it up. I changed the thumbnail size to 200×200 and clicked on the color to set it. When I hit Save, it showed an error at the top saying
    “SyntaxError: malformed hexadecimal character escape sequence”

    The number in the box was from selecting a color. It says #b832c3.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author macguru2000


    I tried but was unable to reproduce this error with the steps you outlined above. Can you please be more specific with the exact step you performed to get this error message.

    When you selected the color, did you use the mouse?

    Was the keep aspect ratio checkbox checked? If not, why change the color, are you using images with alpha channels?

    What browser, os and versions are you using?

    Who is your hosting company and what version of PHP is installed on your server?

    I haven’t heard of this problem before, I would like to fix it, but I cannot reproduce it, so that makes it impossible for me to fix. Looking forward to any help reproducing the error message.

    I figured you hadn’t seen it, or it would have been fixed.
    I used the mouse to select the color (note I said I clicked on the color to set it).
    I did not keep the aspect ratio. I wanted to see the plugin’s color picker. That’s the only reason I chose a color.
    I’m using SeaMonkey 2.8 on Windows 7 64bit.
    I was testing this on a local setup with XAMPP 1.7.3 with PHP 5.3.1.

    I doubt it is specific to my setup. I just tried it again (after having used the plugin awhile) and the message did not show up. I got the message when I first installed and this was the first thing I did.

    Plugin Author macguru2000


    Ok, this is a good start.

    First off, CataBlog does not officially support SeaMonkey, but it seems that it would be very similar to Firefox. Would you mind trying other browsers to see if that is the problem.

    Also, when does the message appear? After you selected a color with the mouse, what did you do? did you save your options? Did you look at other option tabs? When does the message appear, after saving? What admin pages does the error appear on, just the CataBlog Options page?

    If you do not check keep aspect ratio, than you could not see the color in the preview. You were only changing the color behind the preview image, which is scaled to fill the entire preview area. Is this what you wanted? why? Please, check keep aspect ratio for a visual explanation and to see the selected color in the preview.

    I did not write the color picker widget, that is called farbtastic, which is part of WordPress, Drupal, Twitter and others. I don’t think the color picker itself has this bug.

    So, I haven’t seen this message before and after hearing about it from you and trying to recreate the situation that causes the bug, I still haven’t seen it. I need to be able to recreate the bug to fix it. Has anyone else seen or experienced the error message reported above? If so please help by explaining exactly what you did to reproduce the error.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: CataBlog] SyntaxError after setting color’ is closed to new replies.