Support » Plugin: CataBlog » [Plugin: CataBlog] installed and cant see Catalog in admin

  • Resolved DGWordPressUser

    (@dgwordpressuser)


    I have 5 custom post types on my site and it seems that they have used up the slot where catablog would show its menu item.

    If I activate Catablog, then I can see a line in between my other admin menu items, but I cant open or access it. If I deactivate it then the line disappears.

    I have Catablog working on another site of mine which has less menu items.

    Is there a bug causing the menu item to disappear?
    Would the problem be something else?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author macguru2000

    (@macguru2000)

    I am unsure about the specifics, but yes this sounds like a bug.

    After looking at the code, I noticed that I am using an undocumented function to add the CataBlog menu, add_object_page(). This could very well be the problem. You may try replacing that function on line 239 with the documented add_menu_page() function.

    Another idea is that WordPress has a limit of 5 custom menus and you have hit that wall. If this is the case, I do not know what to suggest other then removing one of your custom post types.

    Good luck and let me know if you figure anything out.
    Cheers

    http://codex.wordpress.org/Administration_Menus
    http://codex.wordpress.org/Function_Reference/add_menu_page

    Yes, that worked, thank you.

    I changed in > CataBlog.class.php > public function admin_menu() {

    add_object_page( to add_menu_page(

    Plugin Author macguru2000

    (@macguru2000)

    Glad to hear that fixed the problem. One more fix for the bug tracker 🙂

    Plugin Author macguru2000

    (@macguru2000)

    Version 1.2.5 of CataBlog includes the changes discussed above, incidentally this also means that the position of CataBlog in the admin menu has changed, now it will be displayed at the bottom along with most other modern WordPress plugins.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: CataBlog] installed and cant see Catalog in admin’ is closed to new replies.