Business Directory Plugin
[resolved] Version 2.1 edit listing not working (6 posts)

  1. surroundedby
    Posted 4 years ago #

    Just updated the plugin to the latest version, and certain things are not working. Mainly the edit listing, and the directory button on the single page. Just seems to redirect to the current page.


  2. businessdirectoryplugin
    Plugin Author

    Posted 4 years ago #

    Hi surroundedby,

    Can you be more specific on the thing that aren't working? Specific pages, links to them, steps you followed--I really need to see all these things to help out and reproduce the issue.

    Also, one other thing to note: If you made changes to the templates from 2.0.5 or earlier and placed these in your theme directory, you may wish to remove them temporarily and try things again--we have radically revamped the template system and what you see MAY be the result of having old code still in place.

  3. surroundedby
    Posted 4 years ago #

    Hi, thanks for the quick response.

    Would love to show you, but it's on my localhost. Recently updated to this plugin from it's old format that I currently have hosted on http://www.surroundedby.co.uk/band-directory/ when it was called WP business directory manager.

    I got it all working with the new plugin, and updated this morning.

    Removed all the old templates and added the new ones (businessdirectory-category.tpl.php, businessdirectory-listings.tpl.php).

    The issue I've got is when you are logged in (from a subscribers perspective) the edit listing button just returns you to the same single listing page. I also have a page for the manage listing with the shortcode [WPBUSDIRMANMANAGELISTING]. The same thing happens. The delete button also does not work.

    On the Single page within <div class="button"><?php print(wpbusdirman_post_menu_buttons());?></div> the directory button does not do anything. Looking at it in Firebug it return the following html
    <form action="" method="post">
    <input class="viewlistingsbutton" type="submit" value="Directory">

    It seems the action is empty.

    Tried removing the templates as suggested but destroys the permalinks so just copied the same plugin code and overwrite. Also tried disabling all plugins but this, and same thing.

    I've using a twenty twelve child theme. Any help would be appreciated.

  4. businessdirectoryplugin
    Plugin Author

    Posted 4 years ago #

    Hmmm. This will be tricky to debug since it's not published anywhere. Any chance you can push this to a webhost for us to look at?

    I will have my developer check into the Directory button issue as well.

  5. surroundedby
    Posted 4 years ago #

    Hiya. I've uploaded this to a temporary URL and imported the live datbase minus the images. You'll find it here:

    It's very weird as now the short codes from the 'submit' and 'edit' a listing are not working, as well as the issues above. Works on localhost.

    Not sure how I can give you a FTP or admin details to this but will if needed.

  6. businessdirectoryplugin
    Plugin Author

    Posted 4 years ago #

    Yes, please send those details. Use my contact form: http://businessdirectoryplugin.com/contact/

    Please link to this forum post for context as well.

    The Directory button issue is fixed now, we're going to release 2.1.1 shortly once we collect any other serious issues out there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Business Directory Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.