WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Business Directory Plugin] Google Map Plugin – Sensor parameter issue

[Resolved] [Plugin: Business Directory Plugin] Google Map Plugin – Sensor parameter issue

Viewing 13 replies - 1 through 13 (of 13 total)
  • I am using php 5.4.4 but tested on my local machine php 5.4.3 not sure if this makes a difference.

    It occurs on both instances, but I had to disable it on my live website as users would get this message on every page.

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    ]\Can you tell me what parameters/fields you are using in the Google Maps API? A complete list would help.

    Also, what listing does it choke on, so we can try to reproduce it locally? A link would be most helpful.

    I had to switch off your plugin otherwise my users would get that pop up on every page. Consider placing conditional statement that the google js only loads on the necessary pages.

    I am using all the fields from the available fields, address, state etc.

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    It’s possible several things could be going on here–I need you to try some things out:

    – What about temporarily disabling all other plugins? Does that fix the behavior with Google Maps on? (that would mean a plugin conflict)
    – What if you use fewer fields? Like only address and city/state?

    I need to be able to reproduce this to fix it. We’re definitely not seeing this locally (I have Google Maps installed on the demo: http://businessdirectoryplugin.com/business-directory/ and it works fine.

    I googled this and happens on several other plugins. I am using php 5.4.3 and php 5.4.4 on my local test site and live website.

    My local website has 1 or 2 plugins like page-navi so it is not that.

    I read some stuff and perhaps your code is also not doing this…

    <script type=’text/javascript’ src=’http://maps.googleapis.com/maps/api/js’></script>

    This line of code should have the sensor param set but is getting chopped off somehow. Some other dev/person had the same issue but they did not get resolve

    alert(“The Google Maps API server rejected your request. The \x22sensor\x22 parameter specified in the request must be set to either \x22true\x22 or \x22false\x22.”)

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    Perhaps it related to PHP 5.4. Can we get admin access to your site to see it in action? You can leave it disabled for now. Use the contact form http://businessdirectoryplugin.com/contact/

    Download XAMP Beta

    http://www.apachefriends.org/en/xampp-beta.html

    I am testing on my local machine using this.

    Clean install of WP + your plugins (bd and google map)
    activate and you will see the errors.

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    OK, I sent an updated module for you to try. Let me know how it goes.

    Apologies I found the issue. In my functions.php I had the following code

    /* This handles the  "Remove query strings from static resources" issue (PERFORMANCE - CACHING) */
    function _remove_script_version( $src ){
    	//$parts = explode( '?', $src );
    	//return $parts[0];
    }
    //add_filter( 'script_loader_src', '_remove_script_version', 15, 1 );
    //add_filter( 'style_loader_src', '_remove_script_version', 15, 1 );

    This was chopping off the sensor param thing.

    So the problem is resolved?

    Yes, thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] [Plugin: Business Directory Plugin] Google Map Plugin – Sensor parameter issue’ is closed to new replies.