Support » Plugin: BulletProof Security » [Plugin: BulletProof Security] Loading of BPS pages is extremely slow

  • Resolved PePsY


    Also apply for wordpress 3.4.1
    On linux Ubuntu
    Mysql: 5.1.63-0ubuntu0.11.10.1
    PHP: 5 (5.3.6-13ubuntu3.8)
    Apache: 2.2.20

    When trying to navigate in BPS pages, whatever it’s the BPS home or pushing a button in it, I have to wait between 2min16sec and 2min30sec each time. There is no error in the BPS panel, all is green, every query work very well, except that every of those take more than 2 minutes. The browser stays in “Waiting for host…” state. There is no timeout.

    I tried a fresh 3.4.2 install with only BPS. Still happen.
    I tried also on a fresh 3.4.1 thinking it was maybe a compatibility problem. But it still happen, again.
    I tried with fresh created databases. Nothing to do. Outside BPS, pages load normally. Since BPS must work a lot with the disk, I thought it’s maybe a disk issue. I ran a badblocks check, read-only mode, and 0 bad blocks found.
    Mysql error log: nothing than the starting notice line.
    PHP: I enabled display error ON, but seen no error on pages.
    Apache error log: nothing special.
    Apache, php and mysql were installed with apt-get with no special tweaks and all running on default config. Can someone guide me? What is the source of the problem? Where to search? Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author AITpro


    BPS uses very little disk space and consumes very little memory/resources.

    What i suspect is that another plugin is conflicting with the BPS plugin’s coding or scripts. Try deactivating all of your other plugins and then try going to BPS options pages. If everything is loading at normal speeds then activate your plugins one by one to find the one that is conflicting with BPS.

    Another possibility is that you have a looping situation occurring, but since this is a backend issue then most likely this is not the problem. Typically looping only occurs on the frontside of a website.

    # .htaccess Fix for Infinite Loops
    RewriteEngine On
    RewriteCond %{ENV:REDIRECT_STATUS} 200
    RewriteRule .* - [L]

    Thank you. Unfortunately, even with plugins deactivated, BPS still take a lot of time to load. Even with the anti-infinite loop put in the apache master conf file. But now I can see that it’s not all the time. Yesterday late after midnight, it was still taking more than one minute to load. And now, at 12:01pm it loads automatically. It cannot be the traffic, since I disabled the google search engine integration and that the website is not ready, so it has no visitors. I guess the next thing to do is to verify if it happens at the same time each day. Thanks for your time.

    Plugin Author AITpro


    hmm if the problem fixed itself then you need to check things that are related to connectivity/connection then.

    Your ISP connection.
    Ping and tracert your Servers.
    Contact your Host to have them check connectivity.
    A browser cache problem.
    A computer virus or other computer problem.
    Check your website for malware it might already be hacked.
    Bad Modem or Router.
    Bad Cat cables.

    You listed several interesting things to check when it will happen again. Thank you for your help.

    Plugin Author AITpro


    Yep code does not magically do something different on its own. it either always works as it is written or it does not consistently work because there is an error in the code. If something is interfering with the code intermittently then you will have intermittent problems with the code, but the code will always try to do the same thing that it is written to do. 😉

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: BulletProof Security] Loading of BPS pages is extremely slow’ is closed to new replies.