Support » Plugins and Hacks » [Resolved] [Plugin: BulletProof Security] Feedburner Redirect URLs reporting 403 errors

[Resolved] [Plugin: BulletProof Security] Feedburner Redirect URLs reporting 403 errors

  • I recently installed the plugin and now none of the posts on the Feedburner feed will load. It will throw a 403 error since it doesn’t like “utm_source=feedburner&utm_medium=feed&utm_campaign=”. I try adding and exception, but I can’t get it to work… This is what I have:

    RewriteCond %{QUERY_STRING} utm_source=feedburner&utm_medium=feed&utm_campaign=(.*) [NC]
    RewriteRule . – [S=2]

    Is this correct… If not, can you provide a correct rewrite rule.


Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author AITpro


    BPS does not normally block any Feeds or Feed plugins. Which plugin is this?
    I don’t see anything in that query string that BPS would block. I notice that you have [S=2] for the RewriteRule. Are you trying to add it to your wp-admin .htaccess file? You should not add any RewriteRules in your wp-admin .htaccess file and only add them in your Root .htaccess file.

    I doubt seriously that the real issue is that you need a skip rule for whatever Feedburner plugin you are using, but if you want the correct .htaccess skip / bypass code for that query string it would be…

    # Feedburner skip / bypass
    RewriteCond %{QUERY_STRING} utm_source=feedburner(.*) [NC]
    RewriteRule . - [S=13]

    This skip rule would go above skip rule #12 and if it works then add it to Custom Code in the Plugin fixes text area.

    And this is some interesting looking .htaccess code for “the Feedburner” on the askapache website. I don’t use Feedburner myself, but this .htaccess code does some very nice things.

    And i came across an issue with Feedburner and WPSC that is dated 2010 so it may not still be an issue >>> http://blog.tigertech.net/posts/wp-super-cache-and-feedburner/

    That seemed to work, but if I browse any page after viewing a page coming from a feedburner URL, I get a 403 error.

    Plugin Author AITpro


    What seemed to work?
    Not sure what you mean by “but if I browse any page after viewing a page coming from a feedburner URL, I get a 403 error”?

    I don’t use Feedburner myself so I am not exactly sure about what you are saying.

    Please describe what is working and not working in specific detail. Thanks.

    I got the utm_source working, but If I browse a different page, it throws a 403 error along with a 500 error when it tried to get the custom error page.

    Plugin Author AITpro


    Ok got the first part – the .htaccess skip / bypass rule does do something.
    Now what does “browse a different page” mean?
    What does “get the custom error page” mean?
    Please provide specific details with examples.

    As you see below, the page loads correctly from the feedburner

    When I browse to a different page on the site, I get this error

    If I browse the page from a different source like Google+, Twitter or directly, it doesn’t have this problem.

    Plugin Author AITpro


    So it looks like there is some kind of problem with your site map? Or the way the page with the error is being loaded from the site-map URL.
    The difference between the 2 URLs shows that one is loading a URL that is not coming from your site map and the other URL shows your site map in the URL and the 403 error message “you don’t have permission to access /site-map on this server.”

    I am not sure what you are doing with the site map, but that seems to be the problem. Since i do not really know what you are doing i can only suggest creating a skip / bypass rule like this. This skip rule would go above skip rule #13 and is skip rule #14.

    # Site Map bypass / skip rule
    RewriteCond %{REQUEST_URI} ^/site-map/ [NC]
    RewriteRule . - [S=14]

    or you could probably do something like this if you are treating the site map like it is a page outside of WordPress. The RewriteRule would go after the beginning of the WordPress .htaccess loop.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # RewriteRule for Custom Apps outside of WP
    RewriteRule ^site-map/ - [L]
    Plugin Author AITpro


    Is the issue resolved or not resolved?

    I’m figuring out the issue as it happens to every page with a separate WordPress install… and it seems that Cloudflare might be causing the issue, although I’m checking out every possibility.

    Plugin Author AITpro


    So it has nothing to do with your site map even though the error plainly says the problem is the site map URL? Your other URL that is a normal permalink URL is fine, but the link pointing to your site map is generating an error. Maybe i am missing something here, but why would you have any links at all coming from a site map and going to Feedburner?

    The only issue with CloudFlare occurs with BPS Pro and it is a minor issue. CloudFlare changes the DNS record information for websites so if you need to extract / get DNS record information about a particular website you can no longer get the original DNS info because the DNS records all reflect CloudFlare DNS info. Other than that BPS and BPS Pro work fine with CloudFlare.

    Plugin Author AITpro


    Is the issue resolved or not resolved? Thank you.

    It’s not resolved yet since the web server is on a Virtual Private Server and I need to figure out what is causing the problem… wether or not it’s a configuration problem.

    Plugin Author AITpro


    Ok just post back here and resolve this thread once you figure it out. If this issue was occurring on both screenshots you posted then i would say that BPS is blocking something that should not be blocked, but since it is only occurring with the /site-map link then it is isolated to something having to do with your site map. Thanks.

    Hmm this just made me think of an issue i ran across about a year ago where someone was using invalid or bad characters in their site map links. Bad characters will not only be blocked by BPS, but these could also get you in trouble with Google. So you should go through your site map and make sure you do not have bad characters in your site map URLs.

    Plugin Author AITpro


    Wow i just looked at your site map – it is a disaster. You have all kinds of invalid / bad characters in it. The URLs with valid characters will open your image files – the rest of links with invalid / bad characters generate 404 errors because the are using invalid / bad characters.

    — are invalid / bad characters in a URL


    Your meta tag is not using UTF-8
    <meta http-equiv=”Content-Type” content=”text/html; charset=iso-8859-1″ />

    change it too
    <meta http-equiv=”Content-Type” content=”text/html; charset=UTF-8″ />

    Plugin Author AITpro


    Oh and this is for the subdomain URL that you posted in this thread. Your main site – site map is relatively ok with the exception of it also generates a silent 404 error. So there is an issue in your main site map as well as your subdomain site map.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] [Plugin: BulletProof Security] Feedburner Redirect URLs reporting 403 errors’ is closed to new replies.