Support » Plugin: BulletProof Security » [Plugin: BulletProof Security] EC2 Bitnami WordPress Multisite Errors

  • Resolved John


    Looks like there are permissions issues with my EC2 WP Multisite Bitnami setup.

    Failed to Activate BulletProof Security Root Folder Protection! Your Website is NOT protected with BulletProof Security!


    Cannot write to the secure.htaccess file. Minimum file permission required is 600. (etc)

    The secure.htaccess was where it was supposed to be, it did get made. I ‘Network Activated’ the plugin, then tried to set it up from my main site. This is the latest 3.4 Bitnami AMI.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author AITpro


    BPS should NOT be Network Activated. If your SAPI type is showing DSO and not CGI on the System Info page then you may have to do some manual permissions changes. Let me know what SAPI type you see on the System Info page.

    Is BulletProof Security Network / MU / Multisite Compatible?
    Yes. BulletProof Security contains AutoMagic buttons for Network / MU / Multisite websites. Both sub-directory and sub-domain Master .htaccess code is written / created for your specific Network / MU site. BulletProof Modes should only be Activated on the Primary site. All sub sites are virtual and there is no need to Activate BulletProof Modes on sub sites. This will actually screw up your Primary site. BPS allows only Super Admins to see the BPS menus in sub sites. BPS also works with Network / MU Domain Mapping.

    Thanks! I had tried installing it both ways. Just tried again – into the main site only (not network-activated), just to double check.

    Server API: apache2handler – Your Host Server is using DSO or another SAPI type.

    In Security Status all the Current Permissions match your Recommended Permissions except:

    root folder ../ 755 750.

    I have BPS on my other WP installs and am grateful for your awesome plugin. This is my first crack at a multisite.
    FWIW, bulletproof-security installed into wp-content/plugins/ with owner 1000. But bps-backup installed into wp-content with owner 1, which is the same owner as the blogs.dir (which is where child site’s files and images are saved).

    Plugin Author AITpro


    Since a DSO SAPI uses ownership permissions differently then CGI you will have to manually change folder and file permissions before using the automated functions. Or in other words, you do not really have full automation unless you manually change folder and file permissions prior to using the automated forms in BPS, which are doing things like copying and writing.

    We will be coding a later version of BPS to compensate for these types of Servers with ownership issues. For now unfortunately these manual steps are required below or you could just do everything manually and download and upload files as needed.

    Create secure.htaccess – Change permissions of secure.htaccess file to 777.
    Activate security mode root folder – Change permissions of htaccess file to 666
    Activate security mode admin folder – Change permissions of htaccess file to 777
    Activate Deny All htaccess Folder Protection For The BPS Master htaccess Folder – Change permissions of
    Your_root_folder_location/wp-content/plugins/bulletproof-security/admin/htaccess folder to 777
    Activate Deny All htaccess Folder Protection For The BPS Backup Folder – change permissions of htaccess file to 777 located at
    Backup Your Currently Active .htaccess Files – change bps-backup folder permissions to 777 at
    Backup Your BPS Master .htaccess Files – change master-backups folder permissions to 777 at

    After completing the BPS installation change the permissions of both htaccess files to 644.
    Check security status and reset permissions as recommended.

    Probably that’s a little beyond the scope of my abilities (especially as updates arrive) for the moment. I’ll keep an eye out for the new version. Thanks for your time and a great plugin.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: BulletProof Security] EC2 Bitnami WordPress Multisite Errors’ is closed to new replies.