Support » Plugins and Hacks » [Resolved] [Plugin: BulletProof Security] 500 Internal Server Error

[Resolved] [Plugin: BulletProof Security] 500 Internal Server Error

  • I have installed this plugin successfully on three of my wordpress installs. On the latest however I must have messed something up because I am getting a

    “500 Internal Server Error”

    At first the site pages were not accessible apart from the home page. I put Bullet Proof back into default mode, changed perma links back and forth to get that in the .htaccess file. This seemed to solve the problem so I reactivated Bullet Proof mode and now I can’t access the admin panel or the site.


    Any ideas how I can at least get back to 0 here? I’m a newbie when it comes to .htaccess as I am just learning about this type of thing.

    Also…if I have two WP installs, (one at root and one at sub level), will the root having bullet proof mode activated cause a problem?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author AITpro


    Are you using the new AutoMagic create buttons to create your htaccess files for you? Updating your permalinks was an older method to generate the WordPress rewriting htaccess code, but as long as you are using permalinks then you can now just use the AutoMagic create buttons to create your Master .htaccess files for you with all the correct information for your site. I think what happened is when you reactivated bulletproof mode your Master file was never created for you so you activated the default Master file which is designed for a standard WordPress root installation. your domain name indicates that the site is a subdomain site. debatecamp being the subdomain. Also you would not use the www prefix. this is a mistake. your full domain would be debatecamp.pssda.net – debatecamp takes the place of the www prefix. So you would need to correct this first in your Settings panel. then once you have that corrected use the AutoMagic create buttons to create your Master htaccess files. in your case double check them to make sure the RewriteBase and RewriteRule are correct because you have a subdomain site.

    Since you can’t access the admin panel / WP Dashboard most likely because of the double domain prefix problem then you will need to FTP to your site. download the .htaccess file that is in your root folder and manually add the correct RewriteBase and RewriteRule. I am not exactly sure what that would be for your site. This would depend on where your setup the subdomain. Web host CP or local folders. Whatever the actual folder name of where WordPress is installed is what you want to add for your RewriteRule and RewriteBase. Then upload the htaccess file back to your root folder (root folder of where this WordPress installation actually is).

    And no if you have 2 or more separate WordPress installations under the same domain then you would install BPS on each of them so no there would not be any conflicts or problems between the 2 separate sites.

    Plugin Author AITpro


    Well it looks like you fixed the double domain prefix issue, but i still see coding errors all over the place – both on the main site and the blog Theme. Also there is a broken Viagra link manually added internally to your site incorrectly. Prank by a buddy of yours? LOL I assume you really don’t want the link there, but If you want that link to display correctly you will need to close the starting span tag. This broken link was added internally and manually and not done by an external hacking script because the span tag is enclosed in a p tag so it would have to have been done by manual editing from someone who has access to your site directly and not injected. Also it appears that the link is intentionally supposed to display broken and not actually be correct. Extra CSS styling was added to make it really stand out. hackers do the exact opposite and try to hide their links so it is definitely a prank. LOL Too funny. Also that Theme you are using is very questionable. You might want to consider just recreating the skin / design if you like the design look and install another Theme that is already completed.

    Plugin Author AITpro


    Ok i see the messed up Viagra link has been removed and now a buy cheap amoxicillin link has been added to display correctly. It actually looks like what a hacker would do now, but it is once again a manually internally added link. This link does not have an affiliate id in the URL so i am assuming that it is not intended to be there. Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: BulletProof Security] 500 Internal Server Error’ is closed to new replies.