WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [plugin BUG google-analytics-for-wordpress ] Error massage with Version 3.0

[Resolved] [plugin BUG google-analytics-for-wordpress ] Error massage with Version 3.0

Viewing 15 replies - 16 through 30 (of 30 total)
  • It appears to be possible to comment out lines 596-597 in wp-content/plugins/google-analytics-for-wordpress/googleanalytics.php as long as you don’t need the menu item in the admin interface immediately.

    i use wp 2.8.2 and upgrade the plugin version 3.0 anddddddd

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘GA_Admin::add_config_page’ was given in /home/linkdig/public_html/wp-includes/plugin.php on line 339

    we need answer about how fix it!!! downgrade and desactive is not a option.

    Possible workaround:
    I have the same problem. Developers please fix.
    I deactivated all my plugins and the reactivated them one by one. As long as I don’t reactivate the “Google Analytics for WordPress” version 3.0 my blog is OK.

    I get the same error with WP 2.8.2 and version 3.0 of this plugin.

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘GA_Admin::add_config_page’ was given in /home/sunbeam5/public_html/wp-includes/plugin.php on line 339

    Fixed in 3.0.1, which should appear as an update in 10 minutes or so. Thanks for noticing all of you (although it could be hard not too it seems 😉 )!

    Guys, keep in mind, Yoast does this for FREE!
    (well maybe a few donations)

    Cheers Joost for the update..

    Thanks punkelstein! And about donations… Can’t remember the last one, probably over a month ago…

    hmm… one thing I notice… maybe it’s just me but when I try to update it says it updated the plugin, but then when I go back to the plugin page it still says v3.0 and has prompt to update again? Over and over…

    Excellent work – many thanks Joost!

    Thanks to Joost for fixing this so quickly.
    Cheers
    Morten

    Thank you Joost for the fix !

    Tal

    Thanks for the quick fix!

    Thanks Joost.

    Glad it’s working for all of you now.

    And today I see 3.1.1 AND a changelog for 3.2. Thanks Joost.

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘[Resolved] [plugin BUG google-analytics-for-wordpress ] Error massage with Version 3.0’ is closed to new replies.